Я хочу установить libssl.0.9.8

20

Я пытаюсь установить программу utorrent, и когда я запускаю программу, я получаю

./utserver: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory

Я провожу различные форумы со вчерашнего дня, и до сих пор я не нашел ничего полезного, поэтому, пожалуйста, скажите мне, в чем проблема?

    
задан Muhammad Jawabreh 08.11.2011 в 21:05
источник

4 ответа

16

В общем, вы должны искать программное обеспечение через программный центр или если вам нравится командная строка, вы можете использовать apt-cache search . В этом случае появился следующий пакет (11.10): libssl0.9.8

Вы можете попробовать установить его ( sudo apt-get install libssl0.9.8 ). Если это не поможет, вы можете сообщить нам, какую версию ubuntu вы используете.

    
ответ дан xubuntix 08.11.2011 в 21:32
7

Если вы используете 11.10 (так как вы не упомянули об этом), у вас есть libssl1.0.0 , которое выше 0,9.8. Любая программа, которая нуждается в 0.9.8, также сможет обрабатывать версии выше этого.

Если у вас нет 11.10, у вас есть несколько способов:

  1. Перейдите на сайт OpenSSL: Ссылка и следуйте установкам там.

  2. Перейдите в Ubuntu Packages и скачайте .DEB оттуда: Ссылка

  3. Перейдите в Debian Packages и отгрузите .DEB отсюда: Ссылка

  4. Установите его через apt-get или aptitude :

    • sudo apt-get install libssl0.9.8 - для версии 0.9.8
    • sudo aptitude install libssl0.9.8 - для версии 0.9.8
    • sudo apt-get install libssl1.0.0 - для версии 1.0.0
    • sudo aptitude install libssl1.0.0 - для версии 1.0.0
ответ дан Luis Alvarado 08.11.2011 в 21:35
7

В версии Ubuntu 12.04 с 64-разрядной версией он работал над установкой 32-разрядной версии:

sudo apt-get install libssl0.9.8:i386

Но, конечно, когда вы на 32-битном Ubuntu, это должно просто работать (без :i386 ):

sudo apt-get install libssl0.9.8
    
ответ дан ayke 11.02.2013 в 00:44
0

Просто пробуйте эти шаги, когда вам это нужно для CAV для Linux.

Если вы уже пытались установить папку, но есть ошибка с Libssl0.9.8:

  1. sudo apt-get --purge remove cav-linux
  2. Удалить все libssl0.9.8 из / с помощью Synaptic
  3. sudo apt-get clean
  4. sudo apt-get autoremove
  5. sudo aptitude install libssl0.9.8

, а затем установите нормальный путь.

  1. Создать каталог /opt/COMODO

    Скопируйте файл-файл там:

    cd /opt/COMODO
    sudo dpkg -i cav-linux_1.1.268025-1_amd64.deb
    
  2. Загрузить драйвер и переустановить драйвер

    скопируйте их в /opt/COMODO

    запустить настройку почты:

    sudo /opt/COMODO/post_setup.sh
    
  3. Выполните это, только если вы получите сообщение об ошибке, что модули RedirFS не установлены

    sudo bash /opt/COMODO/fix_rebuild_driver.sh
    sudo /opt/COMODO/post_setup.sh
    
  4. Reboot

ответ дан JDoerr 28.08.2016 в 10:10