Клавиши регулировки громкости работают в единстве, но не в xfce4

20

Мои клавиши регулировки громкости не работают в xfce. Когда я их использовал, на экране отображается индикация того, что громкость изменяется, но громкость не изменяется вообще (то же самое с клавишей отключения звука).

Странно то, что когда я перехожу от xfce к ubuntu, теперь клавиши работают нормально.

Я не знаю, имеет ли это значение, но у меня есть звуковая карта на моем компьютере.

Как заставить клавиши регулировки громкости работать в xfce?

    
задан skeept 15.05.2012 в 18:26
источник

8 ответов

14

Это все еще нарушено в 12.10. Вы можете исправить это, установив xfce4-mixer, а затем вручную выбрав микшеры для управления им, а затем перейдите в редактор настроек xfce4 и введите имя «активной карты». Кнопка отключения звука не будет работать должным образом, вы можете отключить звук, но не включать звук с ним. Все остальное работает, включая уведомления на экране. Это очень сложно заставить все это работать, поэтому я открыл ошибку: Ссылка

Подробно, в xfce4-mixer вы хотите, чтобы он выглядел примерно так:

Это должно показывать только основной уровень громкости вашей звуковой карты. Вам нужно выбрать звуковую карту сверху, а затем нажать «Выбрать элементы управления ...», чтобы добавить элементы управления. Затем в редакторе xfce4-settings вам нужно установить «активную карту» следующим образом:

Под «звуковыми картами» вы увидите список каждой звуковой карты, для которой вы добавили микшеры. Вероятно, у вас будет несколько карт, поэтому здесь можно найти пробную версию и ошибку. Вам нужно скопировать имя правильной карты с «звуковых карт» на «активную карту» - это будет микшер, которым управляют кнопки регулировки громкости.

    
ответ дан Alistair Buxton 03.12.2012 в 01:20
источник
5

xfce4-volumed работает только для меня, когда он работает не в режиме демона. Клавиши тома работают для меня, когда я запускаю эту команду, чтобы убить любые существующие объемные процессы и запустить новый, который не работает в режиме демона:

kill 'pidof xfce4-volumed' ; mkdir -p /tmp/volumed && cd /tmp/volumed && nohup xfce4-volumed --no-daemon &

Выполняет этот процесс, используя nohup, поэтому терминал, в котором вы запускаете эту команду, может быть закрыт, не убивая процесс.

    
ответ дан Stephen Ostermiller 20.02.2014 в 22:52
4

Эти клавиши громкости основаны на гномах ... или на основе единства или что-то еще ... Вам нужно создать пользовательские сочетания клавиш в настройках клавиатуры gui, чтобы уменьшить, увеличить и отключить звук ... Для увеличения громкости команда: «Мастер установки amixer 5% +» для уменьшения объема "мастер настройки микширования 5% -" для немого "переключателя мастер-переключателей-миксеров"

    
ответ дан Arpit Roopchandani 19.05.2012 в 09:05
1

У меня была та же проблема в Xubuntu 12.04, хотя я не знаю, работало бы она в Unity, так как у меня только Xfce4. В терминале введите:

$ xfconf-query -c xfce4-mixer -p /active-card -s xfconf-query -c xfce4-mixer -p /sound-card

Источник: Ссылка

    
ответ дан MrPink 07.06.2012 в 01:44
1

Если это временная проблема, как это было в моем случае, просто выполните ее в командной строке:

killall xfce4-volumed && xfce4-volumed     

ответ дан Felipe 17.12.2015 в 17:56
0

Я исправил проблему, изменив параметр «Активная карта» в редакторе xfce4-settings

У меня есть две звуковые карты (один HDMI и другой обычный), и выбранная карта отличается от обычной карты, которую я использовал.

    
ответ дан Damiano 30.12.2012 в 17:19
0

У меня была и эта очень странная проблема, я мог бы настроить ползунок объема в меню, и он ничего не сделал. Кроме того, если бы я попытался настроить его с помощью клавиатуры, слайдер переместился бы, но ничего не изменилось бы с фактическим объемом.

Я исправил его, перейдя в PulseAudio Volumne Control . На панели Output Devices вы можете увидеть все параметры вашей звуковой карты. Оттуда я убедился, что порт настроен на аналоговый выход. В вашем случае это может быть HDMI или наушники в зависимости от того, где вы хотите, чтобы ваш звук прошел. Затем выберите «установить как резервную опцию». Он выглядит как зеленая галочка.

Я не должен был установить xfce4-mixer , чтобы заставить это работать.

    
ответ дан John 27.12.2014 в 21:27
0

В Settings > Settings Manager > Keyboard > Applications Shortcut :

  • добавить amixer set Master 3+ для увеличения объема
  • добавить amixer set Master 3- для уменьшения объема
  • добавить amixer -D pulse set Master Playback Switch toggle для отключения звука / включения звука
ответ дан dr0i 09.03.2017 в 08:53