Не удается установить Skype 4.3 на Ubuntu 14.04 64 бит

19

Прежде всего, я думаю, что этот вопрос не дублируется, потому что я пробовал все другие решения, которые я нашел здесь, но ничто не решило мою проблему.

Я использую Ubuntu 14.04 64 бит.

Я пробовал до сих пор: sudo apt-get install skype - > Это не сработало. Ошибка:

The following packages have unmet dependencies:
skype : Depends: skype-bin
E: Unable to correct problems, you have held broken packages.

Я пробовал sudo dpkg add-architecture & amp; & amp; & amp; & amp; & amp; & amp; sudo dpkg -i skype-ubuntu-exact_4.3.0.37-1_i386.deb , но это тоже не сработало. Ошибка:

dpkg: dependency problems prevent configuration of skype:
skype depends on libqt4-dbus (>= 4:4.5.3); however:
Package libqt4-dbus is not installed.
skype depends on libqt4-network (>= 4:4.8.0); however:
Package libqt4-network:i386 is not installed.
skype depends on libqt4-xml (>= 4:4.5.3); however:
Package libqt4-xml:i386 is not installed.
skype depends on libqtcore4 (>= 4:4.7.0~beta1); however:
Package libqtcore4:i386 is not installed.
skype depends on libqtgui4 (>= 4:4.8.0); however:
Package libqtgui4:i386 is not installed.
skype depends on libqtwebkit4 (>= 2.2~2011week36); however:
skype depends on libstdc++6 (>= 4.2.1); however:
Package libstdc++6:i386 is not installed.
skype depends on libx11-6; however:
Package libx11-6:i386 is not installed.
skype depends on libxext6; however:
Package libxext6:i386 is not installed.
skype depends on libxss1; however:
Package libxss1:i386 is not installed.
skype depends on libxv1; however:
Package libxv1:i386 is not installed.
skype depends on
dpkg: error processing package skype (--install):
dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.54ubuntu1) ...
Errors were encountered while processing:
skype

Я попытался использовать после sudo apt-get -f install , но это не помогло.

Я попытался установить с помощью Gdebi . Ошибка:

Cannot install 'libqtwebkit4:i386'

Я попытался установить с помощью Программного центра Ubuntu . Ошибка:

Cannot install 'libqtwebkit4:i386'

Я попытался сменить сервер в «Программном обеспечении и обновлениях». Я попытался использовать «Основной сервер» и «Серверы для Соединенных Штатов». Но это не могло решить мою проблему.

Кто-нибудь знает, как это решить?

решаемые

Хорошо, я отформатировал свой компьютер, и я установил Skype в первую очередь. Вероятно, еще одна установка, которую я делал до установки Skype, была проблемой, я думаю.

Спасибо людям!

    
задан z_inx 30.07.2014 в 20:29
источник

9 ответов

32

Я запускаю 14.04 64bit, вот как я установил.

Скачан skype 4.3 из здесь , и я использовал Gdebi, чтобы установить его, и он установил отлично. если у вас нет Gdebi, просто нажмите Ctrl + Alt + T на клавиатуре, чтобы открыть терминал. Когда он откроется, запустите следующие команды:

sudo apt-get install gdebi

Какяужесказал,уменянебылоникакихисходов,используяописанныйвышеметод.Другое,чтовыможетесделать,чтобыисправитьсломанныепакеты,выможетесделать

sudoapt-getclean&&sudoapt-getupdatesudoapt-getupgrade

ИЛИ

Перейдитевдиспетчерсинаптическихпакетов,есливыегоустановили,перейдитевEdit->Исправьтесломанныепакеты.

Альтернативныйспособегоустановки:

sudodpkg--add-architecturei386sudoapt-getupdatewget-Oskype-install.debhttp://www.skype.com/go/getskype-linux-debsudodpkg-iskype-install.deb

Послеэтого,есливыполучитекакую-либоошибку,например,неможетеустановить«libqtwebkit4:i386»иликакой-либодругойпакет,попробуйтеэтукоманду.

sudoapt-getupgrade--fix-missing

Онпредложитвампопробоватьследующуюкоманду.

sudoapt-get-finstall

Послевыполнениявышеуказаннойкомандыповторитеследующуюпроцедуру.

sudodpkg-iskype-install.deb

Дляполучениядополнительнойинформациисм.официальныйфорумSkype .

Надеюсь, это поможет вам :)

    
ответ дан Mitch 30.07.2014 в 20:44
4

Первый запуск:

sudo apt-get install -f

для установки разделов, связанных с OS 14.04LST 64 бит, а затем попробуйте выполнить команды ... skype 4.3 отлично устанавливает

sudo dpkg --add-architecture i386
sudo apt-get update
wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
sudo dpkg -i skype-install.deb

Это сработало для меня .... ;;;; :)     

ответ дан suri 05.08.2014 в 16:13
2

Выполнение следующих команд:

sudo apt-get clean && sudo apt-get update
sudo apt-get upgrade

Решил проблему для меня.

    
ответ дан nick 05.08.2014 в 14:26
2

Шаги:

sudo sh -c "echo 'deb http://archive.canonical.com/ubuntu/ trusty partner' >> /etc/apt/sources.list.d/canonical_partner.list"
sudo apt-get update
sudo apt-get install skype
    
ответ дан John Foley 21.10.2014 в 22:54
1

Я столкнулся с той же проблемой, что и Skype 4.3 на Ubuntu 13.10. Однако, следуя приведенным выше инструкциям, Skype 4.2 всегда появляется в кете, даже при удалении скайпа перед загрузкой более новой версии. Чтобы он работал, мне пришлось удалить конфигурационный файл .Skype в моем домашнем каталоге:

rm -r ~/.Skype

Не беспокойтесь, вы не потеряете свои контакты или что-то еще. Единственное малейшее раздражение, которое я вижу, что сначала , некоторые из ваших контактов будут отображаться со своим именем в скайпе, а не с фамильным полным именем.

    
ответ дан Marc Corluy 25.08.2014 в 12:59
1

В моем случае у меня такая же проблема из-за несоблюдения принципа RTFM :) Установили некоторые пакеты из xorg-edgers, а затем не удалили их должным образом, как сказано в комментарии к установке (т. Е. Просто удалили репозиторий, но не установили пакеты). Это вызвало эффект домино, который может оказаться неспособным установить какие-либо пакеты, зависящие от i386-библиотеки ...

Я нашел его, пытаясь установить пакеты с aptitude, которые непосредственно задают проблемы (разные версии 64-разрядных пакетов). Затем я добавил обратно хранилище xorg-edgers и удалил его с помощью:

sudo apt-get install ppa-purge
sudo ppa-purge xorg-edgers

Надеюсь, это поможет кому-то ...

    
ответ дан Karel Lenc 25.08.2014 в 19:42
1

Я исправил эту ту же проблему, включив «Рекомендуемые обновления (надежные обновления)» в панели управления «Software & amp; Updates», вкладка «Обновления».

    
ответ дан Douglas Held 24.11.2014 в 19:04
0

Я обновился до версии 4.3.0.37 , потому что версия 4.2.0.13 больше не позволяла мне входить в систему с ошибкой «Невозможно подключиться» .

К сожалению, для меня после нескольких часов попыток я не мог заставить pulseaudio работать в моей системе, работает только ALSA, поэтому я понизился до 4.2.0.13

Чтобы решить ошибку входа, я подделал номер версии 4.2.0.13 до последней версии 4.3.0.37 , и логин снова работал, проблема решена.

Итак, чтобы решить вашу проблему, просто перейдите на 4.2.0.13 и обманите версию 4.3.0.37 , выйдите из Skype и запустите эту команду:

sudo sed -i "s/\x34\x2E\x32\x2E\x30\x2E\x31\x33/\x34\x2E\x33\x2E\x30\x2E\x33\x37/g" /usr/bin/skype

После того, как вы сможете войти в систему как обычно.

    
ответ дан mikelinux 12.08.2014 в 09:03
0

Для тех, кто пробовал все выше, но все еще борется (как и я):

Проблема может быть только для сервера, который вы используете для обновления Ubuntu (это было в моем случае). Сервер, который я использовал, не имел правильного определения libqtwebkit4:i386 .

Чтобы решить это:

  • Открыть настройки системы
  • Программное обеспечение и amp; Обновления
  • вкладка Ubuntu Software
  • Загрузите с (Другой ... и выберите Лучший сервер)

Обновите свою систему sudo apt-get update , а затем:

wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
sudo dpkg -i skype-install.deb

Работал для меня.

    
ответ дан Raphael_b 15.05.2015 в 18:17