Раздражающее мерцание в 16.04 LTS - Chrome

199

Я обновил с 4.4.0 до 4.4.8, а затем 4.5.2 на Ubuntu 16.04 LTS 64-bit, и это все еще происходит.

В 4.5.2 он еще чаще, и в основном в Chrome (еще не пробовал firefox или opera). Каждый раз, когда я открываю новую веб-страницу. Любой способ исправить это, или это ошибка?

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
04:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Venus XTX [Radeon HD 8890M / R9 M275X/M375X] (rev 81)

Приветствия.

    
задан Mookey 03.05.2016 в 08:31
источник

11 ответов

189

После некоторых исследований я нашел решение этой проблемы. Сейчас он работает для меня.

Я отключил аппаратное ускорение для моего браузера от

Settings > Advance Settings > System > uncheck the hardware acceleration

Надеюсь, это сработает на вашей машине.

Я использую google-chrome-stable Version 50.0.2661.94 (64-bit) on Ubuntu 16.04

----- EDIT ----

Если вы столкнулись с задержкой прокрутки и разрывом экрана. Сделайте, как предложено Amos Folarin в комментарии ниже:

Перейдите в: chrome://flags/#smooth-scrolling и включите его.

    
ответ дан sgiri 05.05.2016 в 19:54
источник
158

У меня была такая же проблема: настройка растрирования GPU на «принудительно для всех слоев», похоже, наконец-то работает:

    
ответ дан Gondy 08.08.2016 в 09:52
39

Я зафиксировал его следующим образом:

sudo apt-get purge xserver-xorg-video-intel

затем перезагрузитесь. Это связано с тем, что драйверы Intel переместились в режим настройки. Для получения дополнительной информации см. этот комментарий в потоке ошибок Chromium .

    
ответ дан ComBin 19.08.2016 в 16:25
38

Откройте терминал и введите следующую команду:

sudo nano /usr/share/applications/chromium-browser.desktop

и прокрутите вниз, пока не дойдете до этой строки:

Exec= chromium-browser

Затем добавьте эти два параметра

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

Нажмите Ctrl + O, чтобы сохранить и Ctrl + X, чтобы выйти.

Затем введите следующую команду:

sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf

и добавьте эти строки

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
   Option      "TearFree"    "true"
   Option      "DRI"    "3"
EndSection

Нажмите Ctrl + O, затем Ctrl + X.

Откройте Chromium и напишите в адресную строку: chrome://flags/ и введите.

  • Enable-ноль-копию
  • Включить переопределение списка рендеринга программного обеспечения
  • Включить отображение холста 2D-листа

Наконец, откройте настройки хрома и нажмите:

  • Использовать аппаратное ускорение при наличии
ответ дан zafer 27.07.2016 в 10:10
26

Ни один из этих ответов не помог мне. То, что я закончил тем, что кажется , исправил его (моя ссылка была на этот сайт Ссылка , которая мерцала как CRAZY, и теперь он работает плавно):

1.- Перешел на chrome://gpu/ . Вот что он показал:

2.-Япопыталсярешитьпроблемыодинзадругим.Вмоемслучае,чтобыэтифлагификсировалинекоторыеизних:GPUrasterization,Overridesoftwarerenderinglist.Затемонпоказалследующее:

3.-Яредактировалпанельзапускаидобавлялпараметры--disable-gpu-driver-bug-workarounds--enable-native-gpu-memory-buffers.

4.-Послеэтогобольшепроблемнеобнаружено,всепоказываеткак«аппаратноеускорение»и,чтоболееважно,большенемерцает:

Если вы сначала добавите параметры в программу запуска, список проблем должен быть короче, и, вероятно, будет легче определить, какие флажки помогут вам в проблемах, которые у вас остались.

    
ответ дан Nahuel 14.09.2016 в 14:29
7

С Chrome версии 51.0.2704.103 (64-разрядная версия) флаги

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

больше не работают.

Лучший способ сделать это - вернуться к Chrome 50 (версия 50.0.2661.86 (64-разрядная версия)), вот инструкция, как вы можете отступить: как изменить рейтинг google chrome?

Важно, что мы оказываем давление на Google, чтобы исправить эту проблему, проголосовать за ошибку в Chromium и на странице продукта google:

Ссылка

Ссылка

    
ответ дан user157697 19.06.2016 в 10:02
5
chrome://flags/ > GPU rasterization > Enable,

Это, наконец, помогло мне! Нашли его внизу этой формы Google! Ссылка

    
ответ дан Chris Lane Jones 16.10.2016 в 22:44
4

Думаю, я нашел решение:

flags --disable-gpu-driver-bug-обходные пути --enable-native-gpu-memory-buffers, а также enable-zero-copy ENABLE

    sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf
    Section "Device"
       Identifier  "Intel Graphics"
       Driver      "intel"
       Option      "AccelMethod"  "sna"
       Option      "TearFree"    "true"
       Option      "DRI"    "3"
    EndSection
    
ответ дан Hector 07.07.2016 в 17:14
2

Попробуйте выполнить загрузку с некоторыми опциями GPU:

- отключить-gpu-драйвер-обходные ошибки --enable-native-gpu-memory-buffers

После того, как вы попробуете это, вы также можете поиграть с некоторыми настройками рендеринга в следующих флажках: // и увидеть, помогает ли что-то там, но основная часть моих мерцаний рендеринга была решена двумя флагами командной строки. Если у вас есть файл launcher .desktop, добавьте эти флаги в верхнюю запись Exec перед «% U». Вы также можете добавить их в другие записи Exec, чтобы флаги применялись ко всем режимам запуска.

    
ответ дан MattCole3 04.05.2016 в 17:44
2

Я обнаружил, что настоящие исправления не работают для текущей версии chrome, дальнейшие изменения необходимо изменить (по крайней мере, для моей установки).

Я могу подтвердить эту работу (удаляет и мерцание и разрывы) - благодаря Ссылка

Компьютер: XPS13 9343 Графика: 00: 02.0 VGA-совместимый контроллер: Intel Corporation Broadwell-U Integrated Graphics (rev 09) Версия Chrome: версия 54.0.2840.100 (64-разрядная версия)

Настройки

1) Проверьте сообщения об ошибках до и после настроек конфигурации ниже

  • chrome: // gpu
  • сделайте снимок экрана, чтобы вы могли сравнить его.

2) Изменить (для хрома): /usr/share/applications/google-chrome.desktop или для (хром): /usr/share/applications/chromium-browser.desktop

  • Добавить флаги --disable-gpu-driver-bug-обходные пути --enable-native-gpu-memory-buffers
  • Строка
  • должна выглядеть так: Exec=/usr/bin/google-chrome-stable --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers %U

3) sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf добавить это (возможно, вам нужно создать файл):

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
   Option      "TearFree"    "true"
   Option      "DRI"    "3"
EndSection

4) Настройки флагов Chrome: chrome: // flags:

  • Включить ("нулевой скопировать растеризатор"): chrome: // flags / # enable-zero-copy
  • Включить (включить список отображения 2d canvas): chrome: // flags / # enable-display-list-2d-canvas
  • Enable («Переопределить список рендеринга программ»): chrome: // flags / # ignore-gpu-blacklist
  • Включить «Отображать двумерный холст»): chrome: // flags / # enable-display-list-2d-canvas
  • Включить (флаг хрома для плавной прокрутки в linux): chrome: // flags / # smooth-scrolling

5) Я сохранил настройку Chrome > Расширенный > Используйте аппаратное ускорение, если доступно [ сохранить флажок ]. Если вы снимете эту производительность действительно (хотя и уменьшает мерцание, но не разрывает), приведенные выше варианты работали намного лучше для меня.

6) Перезагрузите компьютер.

7) Сравните настройки. хром: // ГПУ

Это полностью устранило мерцание и раздирание для меня.

    
ответ дан Amos Folarin 15.02.2017 в 15:27
1

Отключение аппаратного ускорения приведет к ухудшению производительности браузеров для страниц, содержащих анимации и другие интенсивные задачи с процессором.

Однако, если у вас нет GPU, установленного в вашей системе, тогда подход отключения аппаратного ускорения, предложенный sgiri , лучше для вас.

Но у меня есть графический процессор NVidia , установленный на моем ноутбуке, и я использую настольную ОС Ubuntu. Поэтому я установил собственный двоичный драйвер (версия 352.63). Это сработало для меня, надеюсь, что работа будет работать и в вашей системе Ubuntu.

    
ответ дан user4128091 23.08.2016 в 08:50