Не удалось выполнить немедленную настройку в 'util-linux'

3

Я пытаюсь сделать apt-get dist-upgrade , но получаю ошибку:

E: Could not perform immediate configuration on 'util-linux'.Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)

Как я могу это решить?

    
задан Albert 07.10.2012 в 21:38
источник

1 ответ

5

Похвалив систему, я думаю.

Я попытался сделать apt-get dist-upgrade -o APT::Immediate-Configure=0 , но у меня возникла ошибка цикла зависимостей: E: Couldn't configure pre-depend multiarch-support for libnih-dbus1, probably a dependency cycle.

Затем я попытался apt-get install -f libnih-dbus1 и получил еще одну ошибку:

The following packages have unmet dependencies:
  libc6-dev: Breaks: cmake (< 2.8.4+dfsg.1-5) but 2.8.1-4~lucid1 is to be installed
E: Broken packages'

Затем я попытался обработать sudo apt-get install libc6-dev .

Затем я сделал apt-get install util-linux -f -o APT::Immediate-Configure=0 , который также отлично работал.

Итак, я думаю, что эта проблема решена сейчас.

    
ответ дан Albert 07.10.2012 в 21:56
источник