«gstreamer1.0-libav» Зависимости пакетов не могут быть разрешены [duplicate]

3

Я в Ubuntu 14.04 amd64, я встречал все доступные обновления, но также получаю эти ошибки в медиакодеках. Сначала я получил эту ошибку:

    gstreamer1.0-libav:i386: Depends: libavcodec-extra-54 (>= 6:9.13) but 6:9.16-0ubuntu0.14.04.1+fdkaac is to be installed
                 Depends: libavformat54 (>= 6:9.1-1) but 6:9.16-0ubuntu0.14.04.1+fdkaac is to be installed
                 Depends: libavutil52 (>= 6:9.1-1) but 6:9.16-0ubuntu0.14.04.1+fdkaac is to be installed
                 Depends: libc6 (>= 2.7) but 2.19-0ubuntu6.3 is to be installed
                 Depends: libglib2.0-0 (>= 2.37.3) but 2.40.0-2 is to be installed

После получения этой ошибки я попытался установить эти библиотеки, а затем сделал

    sudo apt-get install libavcodec-extra-54

Это пошло хорошо, и я мог скачать этот пакет. Но никаких других пакетов не было установлено, терминал сказал, что они уже установлены.

Но снова я получаю эту ошибку.

    The following packages have unmet dependencies:
   libavcodec54: 
    
задан Luzan Baral 22.09.2014 в 17:45
источник

1 ответ

5

Вы можете попробовать следующее:

sudo apt-get install libopus0

Тогда:

sudo apt-get install gstreamer1.0-liba

В соответствии с этим он должен работать. Это было для него.

К сожалению, я не нашел причин, почему это работает или почему libavcodec54 этого не делает.

Ссылка

  1. проблема с ubuntu 14.04 с gstreamer1.0-libav
ответ дан Rickard B 22.09.2014 в 18:08
источник