Как исправить ошибку «Не удалось загрузить информацию о репозитории» при обновлении?

3

Как я могу это исправить? Я вообще ничего не могу обновить.

Я попытался переключиться на лучший сервер в настройках.

Когда я делаю sudo apt-get update , это то, что я получаю:

  

W: Не удалось получить    Ссылка Невозможно найти   ожидаемая запись 'universe / binary-1386 / Packages' в файле Release (Wrong   source.list или неверный файл) E: Некоторым индексным файлам не удалось   скачать. Они были проигнорированы или использовались старые. *

Когда я делаю sudo apt-get upgrade , я получаю следующее:

  

Чтение списков пакетов ... Готово

     

Создание дерева зависимостей

     

Чтение информации о состоянии ... Выполнено

     

0 обновлен, 0 вновь установлен, 0 удален и 0 не обновлен.

содержимое моего источника.list:

  

deb Ссылка , ограниченная квантовым юнитом main

.... обновление: при обновлении он ищет 'universe / binary-1386 / Packages'

однако, если я перейду к: ubuntu.mirror.rafal.ca/ubuntu/dists/quantal/Release с Google Chrome, я вижу, что файл на самом деле называется «universe / binary-i386 / Packages» (он с i, а не 1). как я могу исправить это и заставить его ожидать правильный пакет?

    
задан emperor bohe 15.02.2013 в 04:21
источник

1 ответ

5

Похоже, что в какой-то момент вы запустили dpkg --add-architecture 1386 . Если dpkg --print-foreign-architectures показывает 1386 , запуск dpkg --remove-architecture 1386 должен устранить проблему.

    
ответ дан wgrant 15.02.2013 в 05:33
источник