Как установить модуль QtWebKit 3.0 для Qt Creator?

3

Я пытаюсь добавить webview в свой проект, но модуль не установлен. Я новичок в qml и qt, и я не уверен, как установить модуль.

Спасибо

    
задан Javalsu 28.02.2013 в 15:39
источник

1 ответ

5

По умолчанию 12.10, похоже, предоставляется libqtwebkit4 . Но этот пакет из Qt4, поэтому я предполагаю, что вы используете qt5-edgers ppa для предоставления Qt5. Там у вас есть два пакета, которые могут решить вашу проблему:

sudo apt-get install libqt5webkit5-qmlwebkitplugin libqt5webkit5

Итак, если вы используете этот PPA, установите эти два пакета и посмотрите, решит ли он вашу проблему. Если нет, вы можете использовать apt-cache , чтобы попытаться найти нужный пакет:

apt-cache search libqt*webkit*

Если вы ничего не можете найти, вы можете попробовать использовать пакет Qt4, указанный выше, но я сомневаюсь, что он что-то поможет.

Надеюсь, что это поможет.

    
ответ дан Salem 28.02.2013 в 17:01
источник