Не удается обновить из-за «ненадежных» пакетов? [Дубликат]

3

Итак, я пытаюсь применить лодку обновлений и обновлений через встроенную систему обновления Ubuntu ... Но он говорит мне, что обновления / обновления не могут быть завершены, потому что для этого требуется установка «ненадежных» пакетов.

По большей части мое программное обеспечение установлено через программный центр Ubuntu ... Но есть несколько вариантов и концов, которые я установил отдельно ...

Дело в том, что даже обновления базы «Ubuntu» (которые, как я понимаю, как и у Ubuntu) считаются «ненадежными», когда я пытаюсь их установить индивидуально!

У меня была игра в соответствующих настройках, но независимо от того, что я нажимаю, Ubuntu просто не хочет применять эти обновления / обновления!

Что я делаю неправильно?

    
задан Gregory Opera 08.03.2014 в 09:34
источник

1 ответ

5

Если вы установили пакеты из ppa, это может произойти. Чтобы разблокировать обновления, я предлагаю открыть источники программного обеспечения и отменить выбор некоторых из них (временно):

  1. Откройте программный центр Ubuntu,
  2. затем Edit- > Источники программного обеспечения ...
  3. Наконец откройте вкладку «Другое программное обеспечение».

После отмены выбора ppa попробуйте еще раз открыть Software Updater, чтобы запросить обновление. Он должен быстро дать вам ненадежный источник.

Как указано в karel, вы также можете обновить свою систему, используя sudo apt-get update && sudo apt-get upgrade в командной строке. Он подскажет, хотите ли вы установить такие пакеты.     

ответ дан Sylvain Pineau 08.03.2014 в 10:09
источник