Драйвер принтера зависит от libbeecrypt7: i386, но он не находится в репозиториях

3

Я только что сделал новую установку Kubuntu 16.04, и теперь я пытаюсь настроить принтер.

Принтер Canon mf4320d, поэтому я загрузил драйвер с веб-сайта производителя и попытался установить его. Однако во время установки он говорит, что не может найти ни пакет libeecrypt7: i386, ни libeecrypt-dev: i386.

У меня включена архитектура i386, и я уже установил некоторые пакеты i386 из репозиториев, так что это не проблема.

Кроме того, я установил этот же принтер на Xubuntu 14.04 без каких-либо проблем.

Эти пакеты использовались в репозитории юниверсов, но они, похоже, были удалены в самых последних версиях Ubuntu. (примечание: у меня включен репозиторий юниверса)

Что я должен сделать, чтобы установить драйвер? Возможно, загрузка и установка пакетов из предыдущих репозиториев версий ubuntu?

Спасибо!

PD: есть ли причина для удаления этих пакетов из репозиториев?

Изменить: мой вопрос не в том, как установить пакет из репозитория предыдущей версии, мой вопрос состоял в том, что это хорошее решение в этом случае или если есть другое лучшее решение.

    
задан naggety 26.04.2016 в 16:11
источник

2 ответа

5

beecrypt был удален из Debian и, следовательно, из Ubuntu , из-за того, что он не поддерживается его разработчиками и не используется никаким другим пакетом в Debian.

Надеюсь, Canon скоро предоставит пакет, который не зависит от него, но в то же время должно быть хорошо установить пакет Trusty . Вы также можете попытаться найти сторонние репозитории, предоставляя пакет Xenial.

    
ответ дан fkraiem 26.04.2016 в 16:43
источник
0

Более новая версия драйвера Canon (3.40) зависит от пакетов «libgcrypt20: i386» и «libgcrypt20-dev: i386». Поэтому эти пакеты следует устанавливать вместо этого.

    
ответ дан Te Ri 27.12.2017 в 23:32