Открыть терминал при запуске и запуске команды [дубликат]

6

Очень простой вопрос, я новичок в Linux

У меня есть команда запуска при запуске (элементарная ОС):

/home/zachary/Documents/Server108/Server108.sh

Когда я переворачиваю свой ноутбук в команде, запускается в фоновом режиме, и это здорово, но я не могу выполнить команду «Стоп», потому что терминал никогда не открывается. Итак, мой вопрос:

Как заставить терминал открывать, запускать скрипт, а затем оставаться открытым? Нужно ли добавлять строку в файл .sh или добавлять аргументы в команду запуска?

    
задан Zachary Wight 13.04.2016 в 15:38
источник

1 ответ

5

Если вы используете старый GNOME, вы можете добавить к нему что-то вроде этого:

gnome-terminal --command "/path/myscript.sh"

Просто отредактируйте свой запуск с помощью gnome-session-properties GUI. Он должен быть в System - > Свойства или Приложения - > Другое - > Дополнительные настройки или нажмите Alt + F2 и введите его там. Но, по-видимому, это было устарело, и оно не будет работать на GNOME 3 ...

Вы можете попробовать добавить в свою папку ~/.config/autostart файл, скажем, myscript.desktop со следующим содержимым:

[Desktop Entry]
Type=Application
Exec=gnome-terminal --command "/path/myscript.sh"
Hidden=false
X-GNOME-Autostart-enabled=true
Name=Startup Script
Comment=

Над контентом на самом деле находится моя собственная система, созданная с помощью mate-session-properties GUI, и она работает. Только обновил его для GNOME. Фактически это может работать в других средах, вам просто нужно будет сыграть с некоторыми деталями. Добавление Terminal=true с Exec=/path/myscript.sh также работает, и с ним вам не нужно знать команду для запуска вашего терминала.

В MATE это проще, потому что у него все еще есть этот графический интерфейс. Команды называются mate-terminal и mate-session-properties . Вот как это выглядит на моем MATE:

ЯнезнакомсЭлементарнойОС,ивынесказали,какуюрабочуюсредувыиспользуете(можетбыть,Pantheon,скоторойяникогданеработал),ноэтонедолжнобытьиначе.Вамможетпонадобитьсявычислитькомандудлязапускавашеготерминалаипопробоватьзапуститьmy-terminal--helpилипосетитьегоmanpages,чтобынайтиправильныйпараметр(илипростопопробоватьгораздоболеепростоерешениеTerminal=true).

Иеслипокакой-либопричинеTerminal=trueнеработает,ивынеможетеопределитькомандысвоеготерминала,установитеXTerm:

sudoapt-getinstallxterm

Егокомандаxterm-e"/path/myscript.sh .

    
ответ дан GreggD 15.04.2016 в 00:22