Ubuntu 15.10: несколько мониторов не работают в VMware

3

Я обновил Ubuntu 15.04 до Ubuntu 15.10. С тех пор я не могу использовать два монитора. Ubuntu работает как гостевая ОС в VMware.

Я получаю сообщение об ошибке, которое необходимо установить с помощью инструментов VMware. Я переустановил инструменты VMWare, но это не помогает.

Кто-нибудь решил эту проблему? Благодаря

    
задан Marco 04.11.2015 в 10:27
источник

4 ответа

3

У меня была такая же проблема, но она была решена путем удаления vmware-tools и установки open-vm-tools:

sudo vmware-uninstall-tools.pl
sudo apt-get install open-vm-tools-desktop

, а затем перезагрузите. Надеюсь, что это поможет.

    
ответ дан Stephan 05.02.2016 в 16:39
источник
2

Проблема заключается в том, что vmware еще не обновляет свои инструменты. Я потратил около 3 дней на это и до сих пор не решил проблему. Мой лучший совет - вернуться к снимку, предшествующему обновлению до 15.10. Это или попытайтесь вернуть обновление с помощью диспетчера пакетов.

    
ответ дан eskers 10.11.2015 в 19:04
0

Для меня (по крайней мере, в 16.04) решение должно было запускаться:

  • sudo apt-get purge open-vm-tools*
  • ( Игнорировать другие потоки, говорящие, чтобы вручную установить ядро ​​4.6 )
  • Получить VMware для монтирования носителя с помощью инструмента установки VMWare Tools
  • Извлеките .tar.gz в ~/. или где-нибудь в режиме чтения / записи ( бессмысленно смешно, что установщик vmware находится в среде только для чтения, предотвращая установку изнутри )
  • ( еще более смешно смешно, что скрипты в базе их монтирования не работают или ничего не делают )
  • cd в эту извлеченную папку и запустить
  • sudo vmware-install.pl и просто скажите yes для всех
  • Reboot

Я пробовал подход open-vm-tools , и он не работал для какой-либо расширенной функции VMWare, но это делает.

    
ответ дан Enigma 21.09.2016 в 00:26
0

Я обновил с 14.04 LTS до 16.04.1 LTS и имел ту же проблему.

Я сделал:

    sudo apt-get purge open-vm-tools*
    sudo apt-get install open-vm-tools-desktop

Я думаю, что обновление прошло неплохо. С помощью этого метода вы получаете новую установку open-vm-tools-desktop и всех зависимостей. И теперь он работает.

    
ответ дан Didier Gehéniau 12.10.2016 в 18:04