Lubuntu hibernate Xfce Power Manager «не авторизовано»

3

ОС: Lubuntu 14.04
Пакет: Xfce Power Manager
Настройки пакета:
- В AC & gt; Действия & gt; Поставьте компьютер в режим сна, если он неактивен: 15 минут
- Extended & gt; Установите спящий режим бездействия компьютера: спящий режим
Цель: спящий компьютер после 15 минут бездействия
Сообщение об ошибке: не авторизовано
Время ошибки: при спящем режиме

    
задан Jairo Contreras 12.05.2014 в 03:16
источник

4 ответа

4

Следуйте инструкциям для Ubuntu: Как спящий режим на моем компьютере?

То есть сначала протестируйте, затем создайте файл /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla со следующим содержимым:

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes

Обратите внимание, что для создания этого файла необходимы права root. Так, например, используйте sudo nano /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla

    
ответ дан xebeche 22.05.2014 в 08:53
источник
1

У меня была такая же проблема при xubuntu, и это было связано с Light-locker, который, как мне кажется, используется также под lubuntu. Переустановка световой шкаф постоянно устраняет проблему:

sudo aptitude purge light-locker light-locker-settings
sudo aptitude install light-locker light-locker-settings

Я считаю, что удалять и затем снова устанавливать исправленную проблему с политикой.

    
ответ дан sudocrem 20.08.2014 в 10:57
0

Это старый вопрос, но просто чтобы указать на что-то важное, быть осторожным при переустановке Light-locker и light-locker-settings , поскольку это действие также удаляет < strong> lubuntu-desktop * , который может быть неприятным.

Сначала я изучил варианты polkit. Просто входите.

    
ответ дан P Smith 02.07.2016 в 05:37
0

Для Lubuntu 14.04.1 я нахожу /var/lib/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla, где был

[Disable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=no

[Disable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=no

Измените ResultActive на да на оба . Если вы не нашли com.ubuntu.desktop.pkla - попробуйте найти любой файл * .pkla в папке / var / lib / polkit-1 / localauthority для некоторых строк

    
ответ дан Sorcerer 31.08.2014 в 09:32