cifs, smb - не удается монтировать (разрешено отклонение) или перемещаться по общей папке

3

Недавно я столкнулся с этой проблемой. Обычно я перемещаюсь по общей папке локальной сети с компьютера Linux через smb (т. Е. Из man man man с помощью smb:). Теперь, когда я пытаюсь получить доступ к ярлыку или вводить учетные данные снова, я продолжаю получать диалоговое окно с запросом пользователя, домена и пароля.

Итак, я попытался установить местоположение вручную, используя cisf-utils:

sudo mount -t cifs //fileshare1/docs1/user/My\ Documents/shared/Francesco/ /home/frank/used_shared/ -o username=my_user,password=my_pass,domain=my_domain,gid=1000,uid=1000

Я получаю mount error(13): Permission denied .

Я определенно уверен, что у моего пользователя есть разрешение на эту папку, потому что я могу получить к нему доступ с Windows-машины.

Также, если я попытаюсь установить свою личную папку в этом месте, выполните следующие действия:

sudo mount -t cifs //fileshare1/docs5/francesco.azzarello/ /home/frank/mnt_folder -o username=my_user,password=my_pass,domain=my_domain,gid=1000,uid=1000

Я могу получить к нему доступ без проблем.

Для справки Я использую ядро ​​4.2.0-36-generic, а версия mount.cifs - 6.4.

Любая идея о том, как создать один из двух методов?

Обновить Ответ на ponsfrilus

номер 1: вербальная опция возвращает:

_mount.cifs kernel mount options: ip=xxx.xxx.xxx.xxx,unc=\fileshare1\docs1,uid=1000,gid=1000,user=my_user,,domain=my_domain,prefixpath=user/My Documents/shared/Francesco/,pass=********
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)_

Число 2 в основном одно и то же:

_ mount.cifs kernel mount options: ip=xxx.xxx.xxx.xxx,unc=\fileshare1\docs1,iocharset=utf8,file_mode=0777,dir_mode=0777,user=my_user,,domain=my_domain,prefixpath=user/My Documents/shared/Francesco/,pass=********
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)_

И ничего не изменилось с vers = 2.1:

_mount.cifs kernel mount options: ip=xxx.xxx.xxx.xxx,unc=\fileshare1\docs1,vers=2.1,iocharset=utf8,file_mode=0777,dir_mode=0777,user=my_user,,domain=my_domain,prefixpath=user/My Documents/shared/Francesco/,pass=********
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)_

Что касается числа 4, я могу установить docs1 без проблем, но я могу перейти к общей папке в пользователе.

    
задан Frankmtl 04.05.2016 в 13:38
источник

3 ответа

2

Я думаю, что у вас неправильный тип безопасности для сервера, ошибка 13 означает, что сервер не позволяет вам войти.

Вам нужно будет выбрать правильный режим безопасности в команде mount, добавив опцию sec через -o следующим образом:

sec=
   Security mode. Allowed values are:
   ·   none - attempt to connection as a null user (no name)
   ·   krb5 - Use Kerberos version 5 authentication
   ·   krb5i - Use Kerberos authentication and forcibly enable packet 
       signing
   ·   ntlm - Use NTLM password hashing
   ·   ntlmi - Use NTLM password hashing and force packet signing
   ·   ntlmv2 - Use NTLMv2 password hashing
   ·   ntlmv2i - Use NTLMv2 password hashing and force packet signing
   ·   ntlmssp - Use NTLMv2 password hashing encapsulated in Raw NTLMSSP message
   ·   ntlmsspi - Use NTLMv2 password hashing encapsulated in Raw NTLMSSP message, and force packet signing
    
ответ дан Amias 13.05.2016 в 12:55
2

Я почти уверен, что сегодня столкнулся с этой же проблемой на Ubuntu 16.10. Я несколько раз пробовал все предложения в этом потоке, я мог установить один и тот же общий ресурс с помощью Windows Server 2016, и я мог просматривать его с помощью smbclient (% код%). Я даже попробовал файл внешних учетных данных.

Я в конечном итоге наткнулся на исправление - хотя я создал локального пользователя для общего ресурса в окне Windows, он также был присоединен к домену. В основном настройка домена на локальный компьютер smbclient -U brainstrust //WINBOX01/shared мгновенно исправила мою проблему, поэтому оставляю здесь комментарий, надеясь, что это полезно для кого-то там.

Полностью минимальная команда, которую я использовал, была:

sudo mount.cifs -v //WINBOX01/shared /home/geoff/winbox01  --verbose -o user=brainstrust,password=topsecret,domain=WINBOX01
    
ответ дан Geoff Williams 16.03.2017 в 07:51
1
  1. Попробуйте добавить параметр -v для получения подробного вывода:

    sudo mount -v -t cifs // fileshare1 / docs1 / user / My \ Documents / shared / Francesco / / home / frank / mnt_folder -o Имя пользователя = my_user, пароль = my_pass, домен = my_domain, GID = 1000, UID = 1000

  2. Протестируйте эти параметры командой монтирования «iocharset = utf8, rw, file_mode = 0777, dir_mode = 0777»:

    sudo mount -v -t cifs // fileshare1 / docs1 / user / My \ Documents / shared / Francesco / / home / frank / mnt_folder -o имя_пользователя = my_user, пароль = my_pass, domain = my_domain, iocharset = utf8, RW, file_mode = 0777, = 0777 dir_mode

  3. Тестирование, определяющее вариант версии SMB (vers = 2.1), см. вики samba . На странице man mount.cifs:

      

    уегз =              Версия протокола SMB. Допустимые значения:

           ·   1.0 - The classic CIFS/SMBv1 protocol. This is the default.
    
           ·   2.0 - The SMBv2.002 protocol. This was initially introduced in Windows Vista Service Pack 1, and
               Windows Server 2008. Note that the initial release version of Windows Vista spoke a slightly
               different dialect (2.000) that is not supported.
    
           ·   2.1 - The SMBv2.1 protocol that was introduced in Microsoft Windows 7 and Windows Server 2008R2.
    
           ·   3.0 - The SMBv3.0 protocol that was introduced in Microsoft Windows 8 and Windows Server 2012.
    
  4. Наконец, попробуйте установить только первый общий ресурс:

    sudo mount -v -t cifs // fileshare1 / docs1 / / home / frank / mnt_folder -o username = my_user, password = my_pass, domain = my_domain, iocharset = utf8, rw, file_mode = 0777, = 0777 dir_mode

Любой подробный вывод, который вы можете предоставить, может помочь.

    
ответ дан ponsfrilus 12.05.2016 в 01:04