как установить mencoder в ubuntu 14.10?

3

субъект говорит все. Я обновился до Ubuntu 14.10, и по какой-то причине они вывели mencoder из репозиториев ... Мне нужно это для программы, называемой универсальным медиа-сервером, для кодирования видео для воспроизведения на моем ps3 с моего компьютера. как я могу установить его на ubuntu 14.10? спасибо!

    
задан Christopher Champion 12.03.2015 в 15:38
источник

1 ответ

5

Шаг 1: загрузите файл Ubuntu 14.04.deb с Ссылка . Если вы использовали dpkg на этом этапе, чтобы установить это, вы столкнулись бы с проблемами зависимостей. В частности, пакеты libavcodec54 , libavcodec-extra-54 , libavformat54 , libavutil52 и libswscale2 не могут быть установлены в вашей системе. Тем не менее, у вас могут быть установлены более новые пакеты или могут быть доступны более новые пакеты, которые обеспечивают ту же функциональность. Поэтому мы собираемся изменить файл .deb.

Шаг 2: узнайте, какие версии этих пакетов уже установлены в вашей системе:

apt-cache policy libavcodec*

(а также для других пакетов) скажет вам об этом. Если ни один не установлен, но доступен один, скажите, что libavcodec56 имеет кандидата на установку, установите его ( sudo apt-get install libavcodec56 ). Запишите версию, т. Е. Последние две цифры каждого пакета. Обратите внимание, что вам нужно либо libavcodec54 , либо libavcodec-extra-54 , а не оба.

Шаг 3 : загрузите скрипт с именем videbcontrol . Он доступен из здесь . Вы хотите сделать его исполняемым; и если вам не нравится vi , вы можете отредактировать скрипт, найдите строку, которая использует vi (строка 35 текущего скрипта), и измените ее на nano или любой другой предпочтительный редактор.

Шаг 4: запустите скрипт videbcontrol для файла deb:

videbcontrol mencoder_1.1+dfsg1_0ubuntu3_amd64.deb

Или любой файл deb, который вы загрузили. (Здесь вам, возможно, потребуется указать имена путей, но вам не нужно sudo ). Это откроет файл управления deb. В нем вы найдете строку с надписью «Зависит от:», в которой перечислены пакеты, упомянутые на шаге 1. Теперь тщательно замените номера версий теми, которые вы фактически установили на шаге 2. Закрытие редактора сохранит файл .deb als файл .modified.deb.

Шаг 5: Установите измененный файл .deb с помощью sudo dpkg -i mencoder[version].modified.deb . Надеемся, что все зависимости будут выполнены на этом этапе.

Кстати, именно так я установил nixnote2 beta в моей системе с более или менее одинаковыми зависимостями.

    
ответ дан Jos 12.03.2015 в 16:52
источник