Как установить VirtualBox 5.2 + GUI на Ubuntu 16.04.3

4

Я установил VirtualBox из официального репозитория Ubuntu:

  • virtualbox
  • virtualbox-qt
  • virtualbox-ext-pack

После добавления официального репозитория Oracle VirtualBox :

deb http://download.virtualbox.org/virtualbox/debian xenial contrib

И его ключ:

https://www.virtualbox.org/download/oracle_vbox_2016.asc

Теперь я могу установить virtualbox-5.2 . Но он удаляет virtualbox-qt и virtualbox-ext-pack .

Как установить VirtualBox 5.2 и графический интерфейс и пакет расширения?

    
задан Redsandro 14.12.2017 в 23:50
источник

3 ответа

2

Все двоичные файлы, а гостевые дополнения будут включены в из репозитория Oracle . Предыдущие версии виртуального бокса могут быть конфликтующими и должны быть удалены вручную или будут автоматически удалены во время установки. Существующие виртуальные машины будут сохранены.

Нет необходимости загружать и устанавливать пакет DEB.

Пакет расширения в установленной версии виртуального бокса должен быть вручную загружен , а затем , установленный из медиа-менеджера виртуальных машин     

ответ дан Takkat 15.12.2017 в 09:28
источник
2

Имеет точно такую ​​же проблему, получается в VirtualBox-5.2 или даже более ранней версии, вам больше не нужен virtualbox-qt для графического интерфейса.

Мне все еще нужно загрузить Ext-пакет с веб-сайта Virtualbox, но теперь он является плагином и больше не зависит от ОС, поэтому управление пакетами Ubuntu не нужно.     

ответ дан pstar 19.01.2018 в 08:18
1

у вас нет двух версий виртуального бокса одновременно; вы можете установить виртуальный бокс из пакета .deb, загруженного из

  

Linux_Downloads - виртуальный виртуальный диск VM VM

     

и расширения из

     

Загрузки - виртуальный виртуальный диск VM VM - найдите VirtualBox Extension Pack Все поддерживаемые платформы ссылка

первая очистка старой версии

  

apt-get purge virtualbox

, затем загрузите из ссылок выше необходимых файлов и установите

dpkg -i virtualbox.. #[downloaded file name] 
apt-get install -f  #[for fixing dependencies]
vboxmanage extpack install Oracle.. #[extension pack]

после этого у вас должен быть пакет virtualbox + GUI + ext pack

    
ответ дан user688056 15.12.2017 в 01:14