Странный шум в наушниках, когда звук не воспроизводится

32

В Lenovo T440 есть странный звук из моих наушников. Звук похож, когда вы настраиваете радио, но вы получаете неправильную частоту, и вы слышите неприятный шум. Шум начинается, когда Ubuntu 14.04 загружается и заканчивается после выключения. Он выходит только через наушники, звук не слышен через динамики.

Странно, что шум исчезает при воспроизведении какого-либо звука или при вводе звуковых настроек. Но когда звук остановлен, он появляется снова через 10 секунд или меньше. Кроме того, шум идет вниз (или, возможно, даже исчезает), если я поставлю зарядное устройство для ноутбука и остановлю музыку.

Независимо от того, как я меняю уровень громкости, уровень шума одинаков. Похоже, что выход не отключается после остановки звука.

sudo aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC292 Analog [ALC292 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
    
задан user276016 29.04.2014 в 22:20
источник

10 ответов

26

Получена та же проблема для Dell XPS15 (модель 9550, 2015 в Xenial). Решил его в alsamixer и отключил канал loopback .

$ alsamixer

Переход на loopback (все вправо, с ) и установка Disabled с помощью клавиши .

  • Не требуется перезагрузка;
  • Не нужен корень;
  • Постоянно, насколько я заметил.
ответ дан le hollandais volant 15.08.2016 в 18:53
12

У меня была та же проблема на Dell Inspiron 3542, работающем под Ubuntu 14.04.2

Проблемы, по-видимому, присутствуют в функции аудиовоспроизведения.

Шум останавливается при открытии настроек звука или при воспроизведении аудио / видео. Шум начинается снова, когда я перестаю воспроизводить аудио / видео и закрываю настройки звука.

Это решение сработало для меня: Отредактируйте файл

$ sudo nano /usr/lib/pm-utils/power.d/intel-audio-powersave

измените строку

INTEL_AUDIO_POWERSAVE=${INTEL_AUDIO_POWERSAVE:-true}

к

INTEL_AUDIO_POWERSAVE=false

Reboot.

После этого я больше не сталкивался с шумом.

    
ответ дан mmindia 26.04.2015 в 04:17
7

Возможно, ваш аудиоинтерфейс переходит в режим энергосбережения.

Если следующие команды очищают проблему до перезагрузки или изменения источника питания, она имеет какое-то отношение к энергосбережению:

echo 0 | sudo tee /sys/module/snd_hda_intel/parameters/power_save_controller
echo 0 | sudo tee /sys/module/snd_hda_intel/parameters/power_save
    
ответ дан kvbx 09.10.2014 в 15:02
5

У меня была такая же проблема. Я считаю, что это шум, который ваш микрофон поднимает.

Перейдите в Sound Settings , на вкладке Input , установите флажок Mute рядом с% co_de% (не флажок Settings for <microphone_name> Microphone вверху).

Это должно сделать трюк.

    
ответ дан Dean 09.10.2014 в 14:50
3

У меня была точно такая же проблема, и ни один из вышеперечисленных методов не работал для меня.

Мой ноутбук - ASUS ROG-G501JW, а звуковая карта - Realtek.

Я нашел решение в этой теме: Белый и шипящий шум в наушниках, не присутствующих в Windows .

Установка этой строки в /etc/modprobe.d/alsa-base.conf устраняет все мои проблемы:

options snd-hda-intel model=dell-headset-multi
    
ответ дан HatsOn 09.01.2017 в 22:19
2

У вас активирован tlp?

Если это так, отредактируйте / etc / default / tlp и установите значения параметра энергосбережения в 0

SOUND_POWER_SAVE_ON_AC=0
SOUND_POWER_SAVE_ON_BAT=0

это сделало трюк для меня

    
ответ дан Foxtur 09.05.2014 в 04:48
1

Я отключил все входы и шлейф в alsamixer, отключил все связанные с питанием функции, как описано, но все еще есть шум в наушниках.

Я попытался установить окна, чтобы увидеть, есть ли проблема, и не было.

Шум не зависит от какого-либо коэффициента усиления любого выхода или входа. На какой-либо входной сигнал он не влияет или воспроизводится какой-либо звук или нет. Это чистый постоянный белый шум.

Ubuntu 16.04, 4.4.0-83-generic, точность Dell m5800, Realtek ALC3226

00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
    Subsystem: Dell Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
    Flags: bus master, fast devsel, latency 0, IRQ 32
    Memory at f7e34000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel

00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 04)
    Subsystem: Dell 8 Series/C220 Series Chipset High Definition Audio Controller
    Flags: bus master, fast devsel, latency 0, IRQ 31
    Memory at f7e30000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel

В параметрах /etc/modprobe.d/alsa-base.conf i currenttly есть (я попробовал эквивалент dell-headset-multi и hp):

...
snd-hda-intel model=generic
...

В аудиоуслуге Ubuntu он не показывает мощность на выходе. Когда я отключу звук, звук становится меньше 10x.

Кто-нибудь знает обо мне, что я не пробовал?

    
ответ дан nic30 23.07.2017 в 16:26
0

У меня была эта проблема на Dell 3542 с Ubuntu 16.04 GNOME, и она началась, когда я установил TLP для экономии энергии. Поэтому после того, как я увидел здесь, что проблема связана с энергосбережением, я просто удалил TLP, и проблема исчезла.

    
ответ дан Mita_ 06.11.2016 в 14:12
0

У меня была эта проблема на Asus X200ca с ElementaryOS Loki (Ubuntu 16.04) и другим дистрибутивом linux, который я использовал. Я исправил проблему с помощью

  • запустить alsamixer (не в режиме sudo)
  • Перейдите к Auto-mute Mode (используя стрелку вправо)
  • Измените его, чтобы включить (используя стрелку вверх)

Теперь у меня опять нет проблемы.

    
ответ дан Jonathan Sudibya 23.01.2017 в 09:08
0

Я нашел необычную причину моего чрезмерного фонового шума ... моя Цивилизация 5 (работающая через Steam) не выходила должным образом. Фоновый шум, который я слышал, был из игры. Я использовал «htop», чтобы найти и убить все процессы Civilization и, конечно же, шум уменьшался каждый раз, когда я убивал процесс из игры.

Так что не проблема Ubuntu и звука; это было фактически одно конкретное приложение (которое никогда не выходит из права в любом случае).

    
ответ дан Cranky 18.11.2017 в 22:36
0

Я только что нашел этот поток, потому что у меня были и нечеткие наушники, но по другой причине.

У меня есть USB-вентилятор, подключенный к моему ноутбуку, и пока он включен, я слышу пух на наушниках, поэтому проверьте, нет ли каких-либо устройств на ваших USB-портах, вызывающих помехи на вашем звуке, прежде чем тестировать исправления программного обеспечения.

    
ответ дан Gabriel Ziegler 27.09.2018 в 22:12