Сообщение 'E: dpkg был прерван, вы должны вручную запустить' sudo dpkg --configure -a ', чтобы исправить проблему.'

28

Всякий раз, когда я пытаюсь получить обновление, я получаю ошибку в последней строке:

Ign http://in.archive.ubuntu.com trusty-updates/multiverse Translation-en_IN
Ign http://in.archive.ubuntu.com trusty-updates/restricted Translation-en_IN
Ign http://in.archive.ubuntu.com trusty-updates/universe Translation-en_IN
Ign http://in.archive.ubuntu.com trusty-backports/main Translation-en_IN
Ign http://in.archive.ubuntu.com trusty-backports/multiverse Translation-en_IN
Ign http://in.archive.ubuntu.com trusty-backports/restricted Translation-en_IN
Ign http://in.archive.ubuntu.com trusty-backports/universe Translation-en_IN
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

И затем в соответствии с запрошенной ошибкой при запуске:

$ sudo dpkg --configure -a
dpkg: error: parsing file '/var/lib/dpkg/updates/0009' near line 0:
 newline in field name '#padding'

Что теперь? Могу ли я выйти из этой ошибки?

Я попробовал эту ссылку .     

задан user284303 15.06.2014 в 13:55
источник

2 ответа

56

Вы указали неверную ссылку. Попробуйте следующие команды на терминале, чтобы удалить все файлы внутри каталога /var/lib/dpkg/updates ,

cd /var/lib/dpkg/updates
sudo rm *

И затем запустите команду ниже, чтобы получить новые,

sudo apt-get update
    
ответ дан Avinash Raj 15.06.2014 в 14:05
источник
1

Это работает для меня! Я пытался установить драйвер беспроводной сети, когда эта ошибка появилась. Пришлось удалить файлы, а также файлы блокировки.

sudo rm /var/lib/apt/lists/lock
sudo rm /var/cache/apt/archives/lock
cd /var/lib/dpkg/updates
sudo rm *
sudo apt-get update

, а затем вы можете запустить apt-get install для любого пакета, который вы хотите установить

    
ответ дан Aerosum 19.07.2014 в 05:36