Ubuntu linux-headers-generic и множество ошибок зависимостей

4

Я использую Ubuntu 16.04. После некоторых обновлений, если я попытаюсь что-то установить, я получаю сообщение об ошибке:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
10 not fully installed or removed.
Need to get 0 B/11.0 MB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
dpkg: error processing package libcurl3-gnutls:amd64 (--configure):
 package is in a very bad inconsistent state; you should
 reinstall it before attempting configuration
dpkg: error processing package linux-image-generic (--configure):
 package is in a very bad inconsistent state; you should
 reinstall it before attempting configuration
dpkg: error processing package linux-headers-4.4.0-34 (--configure):
 package is in a very bad inconsistent state; you should
 reinstall it before attempting configuration
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of linux-headers-4.4.0-34-generic:
 linux-headers-4.4.0-34-generic depends on linux-headers-4.4.0-34; however:
  Package linux-headers-4.4.0-34 is not configured yet.

dpkg: error processing package linux-headers-4.4.0-34-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-headers-generic:
 linux-headers-generic depends on linux-headers-4.4.0-34-generic; however:
  Package linux-headers-4.4.0-34-generic is not configured yet.

dpkg: error processing package linux-headers-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic:
 linux-generic depends on linux-image-generic (= 4.4.0.34.36); however:
  Package linux-image-generic is not configured yet.
 linux-generic depends on linux-headers-generic (= 4.4.0.34.36); however:
  Package linux-headers-generic is not configured yet.

dpkg: error processingNo apport report written because MaxReports is reached already
    No apport report written because MaxReports is reached already
                                                                  No apport report written because MaxReports is reached already
                                                No apport report written because MaxReports is reached already
                              No apport report written because MaxReports is reached already
            No apport report written because MaxReports is reached already
                                                                           package linux-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: error processing package linux-libc-dev:amd64 (--configure):
 package is in a very bad inconsistent state; you should
 reinstall it before attempting configuration
dpkg: error processing package linux-signed-image-4.4.0-34-generic (--configure):
 package is in a very bad inconsistent state; you should
 reinstall it before attempting configuration
dpkg: dependency problems prevent configuration of linux-signed-image-generic:
 linux-signed-image-generic depends on linux-signed-image-4.4.0-34-generic; however:
  Package linux-signed-image-4.4.0-34-generic is not configured yet.

dpkg: error processing package linux-signed-image-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-signed-generic:
 linux-signed-generic depends on linux-signed-image-generic (= 4.4.0.34.36); however:
  Package linux-signed-image-generic is not configured yet.
 linux-signed-generic depends on linux-headers-generic (= 4.4.0.34.36); however:
  Package linux-headers-generic is not configured yet.

dpkg: error processing package linux-signed-generic (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libcurl3-gnutls:amd64
 linux-image-generic
 linux-headers-4.4.0-34
 linux-headers-4.4.0-34-generic
 linux-headers-generic
 linux-generic
 linux-libc-dev:amd64
 linux-signed-image-4.4.0-34-generic
 linux-signed-image-generic
 linux-signed-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)

Даже если я попытаюсь переустановить предлагаемые пакеты, я получаю ту же ошибку. Некоторые вещи действительно перепутаны. Не могли бы вы заглянуть в это?

Пока я исправлял это, я также получил ошибку: % Co_de%

И ранее сегодня он запрашивал пароль root, но я никогда не настраивал его.

    

задан user_3068807 09.08.2016 в 13:34
источник

0 ответов