Не знаю, как удалить пакеты для обновления с 14.04 до 16.04

4

Я пытаюсь обновить с 14.04 по 16.04 в течение нескольких недель без успеха. Как и многие другие (например, здесь ), я получаю сообщение об ошибке, в котором говорится, что Ubuntu" не смог рассчитать обновление ". Я попытался проверить /var/log/dist-upgrade/apt.log , чтобы узнать, какие пакеты вызывают проблему, и получил список примерно 800 сломанных пакетов .

Broken dpkg:amd64 Breaks on libapache2-mod-php5 [ amd64 ] < 5.5.9+dfsg-1ubuntu4.19 > ( httpd ) (< 5.6.4+dfsg-3~)
Broken perl-base:amd64 Breaks on perl-modules [ amd64 ] < 5.18.2-2ubuntu1.1 > ( perl ) (< 5.22.1~)
Broken findutils:amd64 Breaks on libpython3.4-minimal [ amd64 ] < 3.4.3-1ubuntu1~14.04.4 > ( python ) (< 3.4.4-2)
Broken libgnutls30:amd64 Conflicts on libnettle4 [ amd64 ] < 2.7.1-1ubuntu0.1 > ( libs )
Broken libgnutls30:amd64 Conflicts on libnettle4 [ i386 ] < 2.7.1-1ubuntu0.1 > ( libs )
Broken systemd:amd64 Conflicts on systemd-services [ amd64 ] < 204-5ubuntu20.19 > ( admin )
Broken systemd:amd64 Conflicts on systemd-services [ i386 ] < none > ( none )
Broken texlive-binaries:amd64 Breaks on luatex [ amd64 ] < 0.76.0-3ubuntu1 > ( tex ) (< 2014)
Broken libopencv-core2.4v5:amd64 Conflicts on libopencv-core2.4 [ amd64 ] < 2.4.8+dfsg1-2ubuntu1 > ( libs )
Broken gnome-control-center:amd64 Breaks on libgnome-control-center1 [ amd64 ] < 1:3.6.3-0ubuntu56.1 > ( libs )
Broken xserver-xorg-core:amd64 Conflicts on xserver-xorg-video-glamoregl [ amd64 ] < 0.6.0+git1603170630.347ef4~gd~t > ( x11 )
Broken xserver-xorg-core:amd64 Conflicts on xserver-xorg-video-modesetting [ amd64 ] < 0.8.1-1build1 > ( x11 )
Broken unity-control-center-faces:amd64 Conflicts on gnome-control-center-shared-data [ amd64 ] < 1:3.6.3-0ubuntu56.1 > ( gnome )
Broken libaccount-plugin-generic-oauth:amd64 Conflicts on account-plugin-windows-live [ amd64 ] < 0.11+14.04.20140409.1-0ubuntu2 > ( gnome )
Broken ghc-doc:amd64 Breaks on libghc-transformers-doc [ amd64 ] < 0.3.0.0-5 > ( doc ) (< 0.3.0.0-6)
Broken libasprintf0v5:amd64 Breaks on libasprintf0c2 [ amd64 ] < 0.18.3.1-1ubuntu3 > ( libs )
Broken libopencv-imgproc2.4v5:amd64 Conflicts on libopencv-imgproc2.4 [ amd64 ] < 2.4.8+dfsg1-2ubuntu1 > ( libs )

Список продолжается вечно, но он может уже дать представление о том, что происходит. В любом случае, я отправил отчет об ошибке на трекер Ubuntu и был сказал, что проблема, вероятно, в том, что я установил пакеты PPA, которые несовместимы с новой версией. Они предложили удалить эти пакеты с ppa-purge , в частности из oibaf PPA:

sudo ppa-purge oibaf

Однако, я получаю сообщение об ошибке:

Updating packages lists
PPA to be removed: oibaf ppa
Warning:  Could not find package list for PPA: oibaf ppa

Можно ли понять, как эта проблема может быть решена?

    
задан Arthur Azevedo De Amorim 01.10.2016 в 03:38
источник

0 ответов