Как я могу убедиться, что привязка с apt-get совместима с виртуальными пакетами?

4

Чтобы разрешить использование php5.2 для lucid, я создал ppa ( ppa: txwikinger / php5. 2 ) и создайте там несколько пакетов php5.2. Для того, чтобы отдать предпочтение этим пакетам, я дал инструкции по их подключению. Однако пакеты php5-mcrypt и php5-imap неправильно загружаются из-за зависимости с phpapi, даже phpapi предоставляется, например, php5-cgi, php5-cli, которые доступны. В чем проблема?

    
задан txwikinger 05.09.2010 в 00:46
источник

1 ответ

1

Я нашел проблему. Я ошибся с условиями закрепления.

Edit:

Версия пиннинга не соответствует тому, что может быть найдено или отсутствовало для пакета в зависимости от виртуального пакета.

    
ответ дан txwikinger 05.09.2010 в 04:12
источник