Подключить / отключить VPN из командной строки

101

У меня есть две настройки VPN на моей машине Ubuntu, одна из которых используется vpnc, а другая - PPTP. Это были настройки с использованием интерфейса сетевого администратора GNOME и отлично работают. Однако иногда мне нужно получить доступ к этой машине удаленно - есть ли способ подключиться или отключиться от этих VPN из командной строки?

    
задан Tim Fountain 16.08.2011 в 17:15
источник

2 ответа

147

Если вы хотите взаимодействовать с NetworkManager из командной строки, вы можете использовать команду «nmcli».

список всех соединений NM: nmcli con

начать соединение (wifi, vpn и т. д.): nmcli con up id ConnectionName

down соединение: nmcli con down id ConnectionName

(больше команд nmcli в manclip manclip ).

Также обратите внимание, что обычные пользователи обычно не имеют разрешения на управление сетью. Использование вышеприведенных команд с sudo должно работать для большинства подключений, но VPN, возможно, может завершиться неудачей с помощью «Ошибка: сбой подключения: нет действительных секретов VPN».

Если это произойдет с вами, вполне вероятно, что пароль VPN будет храниться в гнома-ключах вашего пользователя, что делает его недоступным для пользователя root. Этот комментарий объясняет, почему.

Чтобы исправить это, отредактируйте / etc / NetworkManager / system-connections / ConnectionName и в разделе [vpn] измените флаги для пароля :

password-flags=0

И добавьте следующее:

[vpn-secrets]
password=YourPassword

Теперь перезапустите диспетчер сети:

sudo service network-manager restart

Затем запуск VPN-соединения с sudo nmcli con up id ConnectionName должен работать без проблем.

    
ответ дан ihashacks 17.08.2011 в 05:44
источник
3

Ответ ihashacks с комментариями Мэтта работал на меня ... почти. Придется настроить одну строку.

моя строка с флагом пароля фактически читается: «Xauth password-flag». Принятый ответ не будет работать для меня, пока я не перейду к следующему

[vpn]
...
Xauth password-flag=0
IPSec secret-flags=0

[vpn-secrets]
Xauth password=<my pw> ## This is the one I changed.
IPSec secret=<group pw>

Не знаю, почему мои соединения vpn имеют «Xauth» перед каждым упоминанием пароля.

(Извините, это новый ответ, он еще не может комментировать.)

    
ответ дан John 23.03.2015 в 06:03