Запретить gedit создавать файлы с суффиксом ~ ~ (тильда)

121

Я заметил, что в gedit, если я редактирую файл, другой файл создается в том же каталоге (тот, у которого одинаковое имя файла и суффикс тильды ~ ~). Дополнительный файл остается, даже если я закрываю gedit.

Я понимаю необходимость временного файла (например, в случае сбоя), но vim, например, удаляет дополнительный файл, который он создает, когда я его закрываю.

Есть ли способ сделать то же самое с gedit? Возможно, какая-то конфигурация?     

задан George Kastrinis 26.11.2011 в 22:38
источник

7 ответов

131

Это просто резервные копии исходных файлов, которые gedit создает перед сохранением изменений в ваших отредактированных документах.

В настройках gedit вам необходимо отключить Создайте резервную копию файла перед сохранением , и если вы хотите автоматически сохранить свои изменения, автоматически установите таймер с опцией enable Автосохранять файлы каждые X минут .

Таким образом, ~ исчезнет, и ваши последние изменения будут сохранены в файле каждые x минуты в случае сбоя в работе или сбоя компьютера.

Изменения, внесенные в файл, будут сохранены в самом файле, а не во временном файле.

Имейте в виду, что если вы удалите содержимое файла, а автосохранение будет включено, будет шанс, что вы получите сохраненный пустой файл.

Всегда следите за тем, чтобы при закрытии файла, когда автоматическое сохранение включено, содержимое файла верное, иначе отмените их и сохраните файл еще раз.

    
ответ дан Bruno Pereira 26.11.2011 в 23:03
источник
39

GEDIT по умолчанию имеет включенную опцию, которая создает файл резервной копии (с суффиксом ~ для файла резервной копии) каждые 10 минут. Вы можете легко отключить это поведение по умолчанию.

Перейдите в меню gedit в Edit > Предпочтения > Редактор, там вы найдете вариант, который говорит Создать резервную копию файлов перед сохранением . Снимите этот флажок, и все будет готово.

Ниже приведена еще одна опция, которая называется автоматически сохранять файлы каждые ... минуты . Я упоминаю об этом, так как некоторым людям нравится включать опцию резервного копирования, но предпочитают автосохранение реже, например 30 минут или 1 час, в отличие от 10-минутного интервала по умолчанию.

В любом случае, чтобы отключить создание файла ~ (tilde), предшествующее созданию файла, отключите (снимите флажок) Создать резервную копию файлов перед сохранением

Просмотр параметров редактора в gedit:

    

ответ дан Luis Alvarado 26.11.2011 в 22:46
22

Вы можете отключить эти автоматические резервные копии, перейдя в Изменить > Предпочтения и снятие флажка Создание резервных копий файлов перед сохранением на вкладке Редактор :

В качестве альтернативы вы можете использовать терминал для перехода в каталог, в котором вы сохраняете свои файлы, и удалять файлы резервных копий с помощью rm *~ .

    
ответ дан Christopher Kyle Horton 26.11.2011 в 22:47
15

Это происходит потому, что gedit по умолчанию сохраняет файлы резервных копий.

Откройте настройки и отключите эту опцию:

    
ответ дан RolandiXor 26.11.2011 в 22:49
11

Это резервные копии из исходного файла. Вы можете удалить их, если они вам не нужны.

У большинства редакторов есть параметр для включения / выключения создания этих файлов резервных копий. В gedit (редактор по умолчанию) вам нужно отключить «Создать резервную копию файлов перед сохранением» в разделе «Сохранение файла» на вкладке «Редактор» в диалоговом окне «Настройки».

    
ответ дан Florian Diesch 22.06.2012 в 05:20
7

Для тех, кто заинтересован в отключении «gedit, создающего файл резервной копии при сохранении» с помощью команды;

$ gsettings set org.gnome.gedit.preferences.editor create-backup-copy 'false'

Я искал эту команду для интеграции в мои скрипты настройки системы и нигде не нашел ее.

    
ответ дан Thermionix 19.09.2013 в 09:08
4

What are these extra files?

Это резервные файлы, на которые отвечает предыдущий автоответчик.

Is it safe to delete them?

Да, вы можете безопасно удалить их, если вы уверены, что вам не нужна эта конкретная резервная копия.

Is it possible to stop them from appearing at all?

Если вы используете текстовый редактор gedit (текстовый редактор по умолчанию), его можно остановить следующим образом:

  • Откройте текстовый редактор gedit .
  • Перейдите в Изменить - > Настройки из меню. (теперь он находится на верхней панели в Ubuntu, называемом глобальным меню)
  • Выберите вкладку Редактор .
  • Снимите флажок Создать резервную копию файлов перед сохранением .

  • Закройте окно «Настройки»

ответ дан Anwar 22.06.2012 в 05:29