Почему apt-get не устанавливает последнюю версию [duplicate]

5

Я пытаюсь установить последнюю версию Git. Установщик ubuntu apt-get устанавливает версии 1.9.1, а последняя версия - 2.9.1.

То же самое происходит с Докером. Apt-get устанавливает только версию 1.11.2, а последняя версия Docker - версия 1.12. Я хочу установить последнюю версию Docker, то есть версию 1.12, для работы с новейшими функциями.

Есть ли способ установить последнюю версию?

    
задан user3646774 15.07.2016 в 14:59
источник

1 ответ

5

Самый простой способ - добавить PPA для кандидатов на выпуск Git командой Ubuntu Git Maintainers на Ссылка :

sudo add-apt-repository ppa:git-core/candidate
sudo apt-get update
sudo apt-get upgrade

Обратите внимание, что команда «Ubuntu Git Maintainers» также поддерживает PPA для выпусков Git stable , но поскольку вы сказали, что хотите «последнюю» версию, кандидаты на выпуск PPA для Git могут соответствовать вашим предпочтениям лучше. Во многих случаях оба PPA дают вам ту же самую последнюю версию Git (2.9.1, когда это сообщение было написано).

    
ответ дан edwinksl 15.07.2016 в 15:03