Проблема с файлами Mono и .exe

5

Я купил часть программного обеспечения для настройки программных радиоконтроллеров. Он говорит, что он будет работать в Linux, см. Ниже:

  

Цифровое радио работает: Microsoft Windows 2000/2003 / XP Microsoft   Windows Vista / Seven / 2008, Linux Ubuntu или дистрибутив с Mono, 32   или 64 бит, также на виртуальной машине.

     

Linux требует установки пакета Mono, а также Visual Basic   2005. Версия Linux - это тот же исполняемый файл   платформы Windows и может выполняться с использованием Mono. Вам не нужно   Вино. Все тесты были выполнены на Ubuntu Desktop 10.10

Я пробовал несколько недель, чтобы заставить драйверы для кабеля работать в XP или Win7, и я допускаю поражение.
Похоже, Ubuntu может без труда запустить кабель, но теперь я не могу получить программное обеспечение.

Пробовал работать в Ubuntu 10.04 с моно, GUI не удалось, и я получил следующее сообщение: в терминале.

$ mono ~/Desktop/GigRadioLinux/DigitalRadio/DigitalRadio.exe
The entry point method could not be loaded

Для установки Windows требуется использовать 30 нечетных символов Passkey и текстовый файл 4.24k в качестве «лицензии» для ввода во время запуска exe-файла.

Может ли кто-нибудь сказать мне, как я вводил ключ доступа и лицензию на терминал, или это не моя основная проблема? Я не понимаю «метод точки входа». Пробовал Вино, и это тоже не сработало.

Разработчик ответил на мои предыдущие письма re кабельные драйверы, но не ответил на вопросы относительно этого.

Если я упустил что-то важное, дайте мне знать, и я постараюсь предоставить дополнительную информацию.

    
задан Vere Nicolson 16.12.2013 в 11:39
источник

1 ответ

5

Я предполагаю, что вы говорите о этом приложении . Я загрузил его, распаковал его и зашел в каталог, а затем:

sudo apt-get install mono-vbnc
mono DigitalRadio.exe

Я установил ту же ошибку, что и перед установкой среды выполнения VB. Но потом, он загружается просто отлично. Не знаю, работает ли , потому что у меня нет USB-передатчика.

Я также не имею понятия о регистрации. Никакие подсказки не спрашивали меня для деталей. Щелчок на покупку просто загружает окно браузера. Спросите разработчика.

О, и прежде чем я забуду, не используйте 10.04 для рабочего стола. Конечно, не используйте 10.10 для рабочего стола. Они оба давно не поддерживают. Я тестировал это (опять же приложение, а не драйвер) в последней версии Ubuntu (13.10) и Mono 2.10. По крайней мере, я предлагаю Ubuntu 12.04, который поддерживается до 2017 года.

    
ответ дан Oli 16.12.2013 в 11:56