Звук сбрасывается до 100% после перезагрузки на Ubuntu 16.04

6

Это немного загадочная проблема.

Я обновил Ubuntu 14.04 до 16.04. Теперь после каждой перезагрузки громкость звука сбрасывается до 100%.

Это загадочно, потому что это происходит только на одном компьютере, на другом громкость звука сохраняется ОК.

Другая загадка заключается в том, что у меня Ubuntu 14.04 и 16.04 на том же компьютере с общим /home . На Ubuntu 14.04 звук звучит нормально, но на 16.04 он не работает.

Что можно сделать для устранения этой проблемы?     

задан Pilot6 14.06.2016 в 18:09
источник

4 ответа

6

Я создал нового пользователя и обнаружил, что звук работает правильно с новым пользователем. Это означает, что в пользовательских конфигурациях что-то не так. Я нашел несколько конфигураций, и похоже, что проблема решена. Файлы не были в текстовом формате, и я не знаю, что это за формат.

Я удалил все файлы из ~/.config/pulse/ и перезагрузился. Теперь он работает нормально.

Я также удалил все файлы из /root/.config/pulse/ , чтобы исправить 100% объем на экране входа.

Я думаю, что они изменили формат некоторых файлов конфигурации в новой версии pulseaudio . Конфигурация от 14.04 путала pulseaudio в некотором роде.

Я видел некоторые сообщения об ошибках по этой проблеме. Это может случиться, если вы замените версии Ubuntu тем же /home .

Обновление: Это выглядит как ошибка обновления дистрибутива. Я обновил 14.04 до 16.04 на другом компьютере, и была та же проблема.

% файл co_de% необходимо удалить в cookie после обновления.

    
ответ дан Pilot6 14.06.2016 в 19:46
источник
1

Отключите «Keep Settings» в эквалайзере PulseAudio.

    
ответ дан mmress 27.12.2017 в 01:41
0

Вдохновленный ответом Pilot6 дал, я исправил мой, открыв /home/dell/.config/pulse/default.pa в Gedit и выполнив поиск тома. Он нашел его в 2-х местах и изменил второй, который обнаружил в следующем, чтобы установить мой загрузочный том на 63%.

Предыдущая запись:

set-sink-volume alsa_output.pci-0000_00_1b.0.analog-stereo 65536

Новая запись:

set-sink-volume alsa_output.pci-0000_00_1b.0.analog-stereo 41288

Привилегии суперпользователя не были необходимы, я просто сделал одно простое изменение и перезапустил машину, и он работал нормально. Просто разделите 65536 на любой процент, который вы хотите установить, если вы не хотите 63%.

Надеюсь, что это поможет.

    
ответ дан Ed Hastie 04.07.2016 в 16:24
0

Чтобы устранить эту проблему, откройте терминал, используя (Ctrl + Alt + T) и введите следующее:

amixer -D pulse sset Master toggle

Если вы хотите изменить его на определенный процентный тип ниже, заменив 50% на требуемый объем:

amixer -D pulse sset Master 50%

Любые проблемы, дайте мне знать. :)     

ответ дан proprocastinator 14.06.2016 в 19:14