Не удается установить pgadmin3 на ubuntu 16.04

5

После того, как я попробую sudo apt-get install pgadmin3 , я получаю это сообщение:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 pgadmin3 : Depends: libwxbase2.8-0 (>= 2.8.12.1) but it is not installable
            Depends: libwxgtk2.8-0 (>= 2.8.12.1) but it is not installable
            Recommends: pgagent but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Как я могу это исправить?

    
задан Bozidar Milivojevic 06.06.2016 в 15:31
источник

3 ответа

3

У меня была такая же проблема, и после того, как я ударил головой об этом, достаточно давно понял, что у меня есть устаревший pgdg.list в моих источниках. После удаления и повторного добавления, все отлично.

sudo rm /etc/apt/sources.list.d/pgdg.*
echo "deb http://apt.postgresql.org/pub/repos/apt/ xenial-pgdg main" | sudo tee /etc/apt/sources.list.d/pgdg.list
wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add -
sudo apt-get update -y
sudo apt-get install pgadmin3
    
ответ дан radshop 28.09.2016 в 05:47
2

Попробуйте добавить в систему следующий репозиторий:

sudo sh -c 'echo "deb http://apt.postgresql.org/pub/repos/apt/ 'lsb_release -cs'-pgdg main" >> /etc/apt/sources.list.d/pgdg.list'
wget -q https://www.postgresql.org/media/keys/ACCC4CF8.asc -O - | sudo apt-key add -

У меня была такая же проблема, и мне это помогло.

    
ответ дан snikolaev 13.07.2016 в 18:00
1

У меня была такая же проблема, и вот как я ее исправил:
1) когда я попытался запустить sudo apt-get install libwxbase2.8-0 libwxgtk2.8-0 apt-get сказал мне, что у меня неиспользуемые зависимости - pgadmin3-data и pgagent поэтому я лучше удалю их
2) sudo apt autoremove - удалили их
3) sudo apt-get install pgadmin3 - сказал мне, что ему нужно загрузить некоторые необходимые зависимости (те, которые я просто удаляю). Я сказал «да», и установка прошла нормально. Теперь я могу использовать pgadmin3.

    
ответ дан Boyan 25.08.2016 в 17:44