Полностью застрял с Apt-Get (ничего не установит)

5

Я тестировал 13.04 новый рабочий стол Ubuntu и люблю его. До сих пор у меня были только незначительные ошибки, но сегодня я попытался установить SDK из ubuntu.

Я выполнил 2 шага (установка из терминала), и я получил следующую ошибку:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 qtmultimedia5-dev : Hängt ab von: libqt5multimediaquick-p5 (= 5.0.1-0ubuntu1) soll aber nicht installiert werden
E: Unerfüllte Abhängigkeiten. Versuchen Sie "apt-get -f install" ohne Angabe eines Pakets (oder geben Sie eine Lösung an).

, который переводится на

The following packages have unmet dependencies: qtmultimedia5-dev: Depends: libqt5multimediaquick-p5 (= 5.0.1-0ubuntu1) but it should not be installed
E: Unmet dependencies. Try 'apt-get-f install. "Without specifying a package (or specify a solution)

Его в немецком (я живу в Германии, но из Великобритании), но в основном это относится к отсутствующей зависимости, однако зависимости не устанавливаются.

Я попробовал следующую команду для исправления зависимостей:

sudo apt-get -f install

Но получилось следующее:

dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/libqt5multimediaquick-p5_5.0.1-0ubuntu1_i386.deb (--unpack):
 Versuch, "/usr/lib/i386-linux-gnu/libQt5MultimediaQuick_p.so.5.0" zu überschreiben, welches auch in Paket libqt5multimediaquick5 5.0.0-0ubuntu1~test2 ist
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/libqt5multimediaquick-p5_5.0.1-0ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

, который переводится на

dpkg: error processing / var/cache/apt/archives/libqt5multimediaquick-p5_5.0.1-0ubuntu1_i386.deb (- unpack):
      Trying to overwrite '/ usr/lib/i386-linux-gnu/libQt5MultimediaQuick_p.so.5.0', which is also in package libqt5multimediaquick5 5.0.0-0ubuntu1 ~ test2
     Errors were encountered while processing:
      / var/cache/apt/archives/libqt5multimediaquick-p5_5.0.1-0ubuntu1_i386.deb
     E: Sub-process / usr / bin / dpkg returned an error code (1)

С тех пор. Я не могу установить или удалить программы. Я также пробовал:

sudo apt-get clean (and autoclean)
sudo apt-get -u dist-upgrade
sudo dpkg --configure -a

Я даже пробовал прохождение на следующей странице:

Как разрешить неудовлетворенные зависимости после добавления PPA?

Я все еще не могу заставить его работать! У кого-нибудь есть предложение?

Пожалуйста, помогите мне исправить aptitude.

    
задан Ashley Johnson 19.02.2013 в 00:09
источник

1 ответ

7

Просто принудительно перезаписывайте при установке конфликтного пакета:

sudo dpkg --force-overwrite -i /var/cache/apt/archives/libqt5multimediaquick-p5_5.0.1-0ubuntu1_i386.deb

Если этого недостаточно для успешной установки, вы также можете заставить все, на что может жаловаться dpkg (будьте осторожны!):

sudo dpkg --force-all -i /var/cache/apt/archives/libqt5multimediaquick-p5_5.0.1-0ubuntu1_i386.deb

После этого просто выпустите предлагаемую команду еще раз:

sudo apt-get -f install
    
ответ дан Jorge Suárez de Lis 19.02.2013 в 01:22
источник