Как использовать aptitude для понижения / принудительной версии пакета?

5

Я решил, что мне нравится aptitude лучше всех альтернатив, которые я пробовал. Но я не могу понять, как сменить версию пакета. Я должен вернуться и использовать для этого synaptic .

Как использовать aptitude для понижения пакета?

    
задан Organic Marble 05.04.2017 в 20:01
источник

1 ответ

5

Что-то вроде этого будет работать:

sudo aptitude install package-name=package-version

Например:

$ aptitude versions firefox$

Package firefox:                         
p   45.0.2+build1-0ubuntu1             xenial                         500 
i   52.0.2+build1-0ubuntu0.16.04.1     xenial-security,xenial-updates 500 

Тогда:

sudo aptitude install firefox=45.0.2+build1-0ubuntu1

И с графическим интерфейсом:

    

ответ дан Ravexina 05.04.2017 в 20:16
источник