Попытка установить php-zip - получение ошибки libzip4 dependency (= 1.0), даже если у меня установлен 1.0.1

0

Я пытаюсь установить плагин php zip

Я запускаю:

sudo apt-get install php-zip (also php7.0-zip) 

Я получаю зависимость отсутствия возврата для libzip4 (> = 1.0), но когда я пытаюсь установить или обновить libzip4 с помощью apt-get - он показывает, что у меня установлен 1.0.1 (я думаю, он может иметь имя пакета или псевдоним libzip4: i386 - > не уверен, связано ли это с этой проблемой или нет, но соглашение об именах выглядит странно для меня по сравнению с другими плагинами php, которые я установил).

Команды терминала с выходом:

sudo apt-get install php-zip

Чтение списков пакетов ... Готово Создание дерева зависимостей
Чтение информации о состоянии ... Готово Обратите внимание, выбирая «php7.0-zip» вместо «php-zip», Некоторые пакеты не могут быть установлены. Это может означать, что у вас есть запросил невозможную ситуацию или если вы используете неустойчивый что некоторые необходимые пакеты еще не созданы или выведен из Incoming. Следующая информация может помочь в разрешении ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:  php7.0-zip: Зависит от libzip4 (> = 1.0), но не устанавливается

E: невозможно устранить проблемы, у вас есть сломанные пакеты.

& Amp; & Amp;

sudo apt-get install libzip4

Чтение списков пакетов ... Готово Создание дерева зависимостей
Чтение информации о состоянии ... Готово libzip4: i386 - это уже самая новая версия (1.0.1-0ubuntu1). 0 обновлено, 0 вновь установлено, 0 удалено и 20 не обновлены.

СИСТЕМА:

Lenovo G500 работает под управлением Ubuntu Xenial 16.04 для настольных компьютеров php / apache2 стандартная сборка (стопку Ubuntu LAMP) Версия php: 7.0.15-0ubuntu0.16.04.4

Любая помощь очень ценится !!

ИЗМЕНИТЬ : Я также пытался установить (я считаю, что это тот же плагин) с PECL :

sudo pecl install zip

загрузка zip-1.14.0.tgz ... Начиная с загрузки zip-1.14.0.tgz (248,476 bytes) .............................. выполнено: 248,476 байт 8 исходных файлов, построение running: phpize sh: 1: phpize: не найдено ОШИБКА: «phpize» не удалось

    
задан MJHd 07.07.2017 в 23:13
источник

2 ответа

-1

libzip4: i386 - это 32-разрядный пакет. и конфликтует с 64-битной версией. вы используете 32-битный компьютер?

, если вы используете 64-битный, тогда выполните:
sudo apt-get purge libzip4

тогда:
sudo apt-get install php-zip

, если вы используете 32-бит, тогда:
sudo apt-get install php-zip:i386

    
ответ дан ravery 07.07.2017 в 23:22
источник
0

@ Ответ ravery дал мне на полпути:

Проблема, хотя и не была конфликтом, а просто заключалась в том, что 32-разрядный пакет не будет удовлетворять требованиям к требованиям для установки на 64 бита (хотя вы можете установить 32 версии программного обеспечения в целом с 32-разрядными зависимостями), по крайней мере в этом случае (или вообще - я понятия не имею).

К сожалению, 64-разрядная версия либо не имеет кандидата на установку, либо имеет другое имя пакета, которое я не знаю и не могу найти в Интернете.

sudo apt-get install libzip4  

Чтение списков пакетов ... Готово Создание дерева зависимостей
Чтение информации о состоянии ... Готово Пакет libzip4 недоступен, но ссылается на другой пакет. Это может означать, что пакет отсутствует, был устарел или доступен только из другого источника

E: Пакет 'libzip4' не имеет кандидата на установку

Я не могу найти ppa для 64-битного пакета ...

Если вы следуете советам @ravery и делаете:

sudo apt-get purge libzip4

Вы получаете:

Чтение списков пакетов ... Готово Создание дерева зависимостей
Чтение информации о состоянии ... Готово Следующие пакеты будут удалены:   libzip4: i386 * 0 обновлено, 0 вновь установлено, 1 для удаления и 20 не обновлено. После этой операции освободится дисковое пространство 121 КБ. Вы хотите продолжить? [Y / n] y (Чтение базы данных ... 311771 файлов и каталогов, установленных в настоящее время.) Удаление libzip4: i386 (1.0.1-0ubuntu1) ... Очистка файлов конфигурации для libzip4: i386 (1.0.1-0ubuntu1) ... Обработка триггеров для libc-bin (2.23-0ubuntu9) ...

Итак, теперь 32-битная версия удалена

Тогда:

Перейдите в pkgs.org: Ссылка

Здесь вы можете загрузить и вручную установить 64-разрядный пакет .deb, который apt-get либо не имеет, либо не может найти по имени ...

Наконец Просто запустите:

sudo apt-get install php-zip

Проблема с зависимостями разрешена, и плагин устанавливается нормально!     

ответ дан MJHd 07.07.2017 в 23:44