Chromium 34 и позже не могут обнаружить флеш-плагин

49

Я удалил содержимое ~/.macromedia и ~/.adobe и после перезапуска хром не смог обнаружить flash-плагин. Он отлично работает в Firefox

У меня есть только «Chromoting Viewer» на chrome://plugins/

chromium-browser 34.0.1847.116-0ubuntu2
adobe-flashplugin 11.2.202.350-0trusty1

У меня profile-sync-daemon активен (конечно, остановил его, конечно) и сломал PolicyKit, как в NetworkManager, сломанный после обновления до Kubuntu Saucy

Зависит ли обнаружение от PolicyKit? Что еще я могу сделать?

    
задан int_ua 17.04.2014 в 17:44
источник

6 ответов

83

Chromium 34 в основных репозиториях начал использовать Aura (ранний), который не включает поддержку NPAPI (это запланированный поэтапный отказ от NPAPI в Chromium). Поэтому вам нужно использовать Pepper Flash для использования Flash.

Установка Flash

Ubuntu 14.04 (доверенный) и более новый

Если у вас есть Trusty, вы можете просто запустить sudo apt-get install pepperflashplugin-nonfree .

Ubuntu 12.04 (Точный) и более новый

Если у вас нет Trusty, вы можете использовать этот PPA для установки Pepper Flash для любого поддерживаемая версия Ubuntu выше Precise. Выполните следующие команды, чтобы добавить PPA и установить Pepper Flash:

sudo apt-add-repository ppa:skunk/pepper-flash
sudo apt-get update
sudo apt-get install pepflashplugin-installer

Обратите внимание, что вам нужно настроить Chromium для использования Pepper Flash. Для этого откройте /etc/chromium-browser/default и добавьте следующую строку в конец файла в новой строке:

. /usr/lib/pepflashplugin-installer/pepflashplayer.sh

Закройте все окна и снова откройте.

Обновление Pepper Flash (on Trusty)

Вы можете запустить sudo update-pepperflashplugin-nonfree --status , чтобы узнать, какую версию Pepper Flash вы установили. Если доступна более новая версия, вы можете просто запустить sudo update-pepperflashplugin-nonfree --install .

    
ответ дан saiarcot895 17.04.2014 в 23:25
источник
10

Я не знаю точно, но я нашел здесь , что поддержка Adobe Flash Player закончилась для Chromium с апреля 2014 года. Я думаю, что лучше использовать Firefox или вы могли бы использовать Google Chrome, а не Chromium.

    
ответ дан ganezdragon 29.04.2014 в 19:20
6

Chromium отказался от поддержки плагинов NPAPI , в пользу их PPAPI. Одним из них является «Adobe Flash Player», который с апреля не будет работать ни в одной версии Chrome / ium. У Chrome есть преимущество, которое включает в себя плагин PepperFlash, который является PPAPI, поэтому, возможно, вы должны использовать его или использовать Firefox в то же время.

    
ответ дан Braiam 30.04.2014 в 01:51
5

Ubuntu 14.04

 sudo apt-get install pepperflashplugin-nonfree

работал для меня.

    
ответ дан int_ua 18.04.2014 в 12:32
1

Если ничего не работает ...

Загрузите файл Google chrome .deb из Google, в него входит Adobe Flash Player.

Ссылка

    
ответ дан Rishabh Upadhyay 31.10.2014 в 17:24
0

У меня есть в ~ / .profile параметр:

export CHROME_USER_FLAGS="--disk-cache-size=50000000 --media-cache-size=25000000"

, который испортил настройки / etc / chromium-browser / default удаление этой строки решило проблему с flash-плеером

    
ответ дан agroszer 21.04.2014 в 20:49