Ошибка Eclipse Juno C ++: программа «g ++» не найдена в PATH

5

Я установил новейшую Eclipse Juno вручную (не через программный центр или apt-get), а затем установил Eclipse CDT из справки > установите новое программное меню.

Однако, когда я пытаюсь скомпилировать простой код на C ++, он показывает ошибки, например Программа «g ++», не найденная в PATH.

Я попробовал g ++ с терминала, и он работал отлично. Кто-нибудь знает, где может быть проблема?

    
задан troll 04.08.2012 в 10:12
источник

5 ответов

3

Вы должны установить build-essential

sudo apt-get install build-essential

после установки этого, откройте терминал и введите g++ (нажмите ввод) если он говорит, что нет ввода, тогда вы получили свой g ++

даже после того, как вы установили это, у вас все еще могут быть проблемы с eclipse cdt поэтому я действительно рекомендую Netbeans, нажмите здесь .

Все, что вам нужно сделать, это загрузить Netbeans на ваш компьютер, скажем, что это находится в папке Download

sudo chmod +x your_download_netbeans.sh

то ./your_download_netbeans.sh

Поскольку вы уже установили Eclipse на свой компьютер, я думаю, что у вас уже установлен jdk.

    
ответ дан shengy 12.09.2012 в 04:07
источник
4

Раздражающая проблема, ответы не находят ... Я добавил переменную пути к переменным среды в Window/preferences/build/environment Это работает с тех пор.

    
ответ дан kori 02.09.2012 в 22:47
0

Компилятор g ++ находится в каталоге / usr / bin. Создается файл «sources.mk» и содержит путь к компилятору. Путь не создается. Я отредактировал файл, чтобы добавить путь к параметру C ++ _ SRCS. Игнорируйте, не редактируйте вверху.

C ++ _ SRCS: = / usr / bin

Убедитесь, что вы выполнили «установку необходимых», как описано выше.

    
ответ дан Gordon Morrison 14.06.2013 в 16:07
0

У меня была аналогичная проблема, и я решил ее:

  1. Установка g ++ Компилятор GNU C ++ с помощью программного обеспечения Ubuntu Software Center

  2. Изменение в: Окно - > Предпочтения - > C / C ++ - > Build - > Настройки - > Открытие - > CDT GCC Построение в настройках Complier [Общие]
    от: ${COMMAND} -E -P -v -dD "${INPUTS}"
    to: /usr/bin/${COMMAND} -E -P -v -dD "${INPUTS}"

Надеюсь, это поможет.

    
ответ дан Shashi 05.08.2013 в 01:48
0

У меня была аналогичная проблема, и я решил ее:

Установка g ++ Компилятор GNU C ++ с использованием программного обеспечения Ubuntu Software Center

Изменение в: Window - > Preferences - > C/C++ - > Build - > Settings - > Discovery - > CDT GCC Build in Complier Settings [Shared]

from:

${COMMAND} -E -P -v -dD "${INPUTS}"

to:

/usr/bin/${COMMAND} -E -P -v -dD "${INPUTS}"
    
ответ дан Akash5288 06.12.2013 в 20:00