Как установить glib?

33

Я хочу создать Empathy в Ubuntu 11.04. Когда я следую процессу сборки,

 ./autogen.sh

Оболочка сказала мне, что

libtoolize: copying file 'm4/lt~obsolete.m4'
checking for autoconf >= 2.53...
testing autoconf2.50... not found.
testing autoconf... found 2.67
checking for automake >= 1.9...
testing automake-1.11... found 1.11.1
checking for libtool >= 1.5...
testing libtoolize... found 2.2.6b
checking for glib-gettext >= 2.2.0...
testing glib-gettextize... not found.
***Error***: You must have glib-gettext >= 2.2.0 installed
to build Empathy.  Download the appropriate package for
from your distribution or get the source tarball at
ftp://ftp.gtk.org/pub/gtk/v2.2/glib-2.2.0.tar.gz

Но когда я не могу найти способ установить glib. Что мне делать установить это в ubuntu 11?

    
задан Kim 23.08.2011 в 06:47
источник

3 ответа

73

Для glib-gettext вам нужен libglib2.0-dev . Вы можете установить его с помощью

sudo apt-get install libglib2.0-dev
    
ответ дан binW 23.08.2011 в 14:40
3

Я рекомендую вам искать доступные ppa, если вы хотите просто проверить новую эмпатию, чем у вас. Я думаю, что это ppa - лучший выбор или просто сделать это

sudo add-apt-repository ppa:telepathy/ppa

Или, если вам нужно его построить.

sudo apt-get build-dep empathy

, который установит все зависимости, необходимые для создания эмпатии из источника.     

ответ дан sagarchalise 23.08.2011 в 07:10
3

вам также необходимо установить libgtk2.0-dev для полной установки glib (glib является частью: libgtk2.0-dev)

sudo apt-get install libgtk2.0-dev

см. эту ссылку для получения дополнительной информации: установка gtk и glib

    
ответ дан Ali.A 21.10.2013 в 18:56