Динамик Bluetooth: предпочтительный режим «Высокое воспроизведение воспроизведения» (A2DP) не сохраняется

37

UPDATE Aug 2017: решение, помеченное как принятое мной apppears, работало до Ubuntu 15.10. Для 16.04+ выберите одно из последних решений.

Для 16.04+ конфигурационный файл /etc/bluetooth/main.conf NOT /etc/bluetooth/audio.conf.

У меня есть динамик bluetooth, Sony SRS-BTX300, который работает в linux / ubuntu 13.04, но только после некоторого ворчания. (Обновление декабря 2013 года: те же проблемы остаются в 13.10)

Мне нужно настроить режим предпочтительной полосы пропускания на «Воспроизведение высокой точности воспроизведения» (A2DP) каждый раз после включения компьютера и повторного подключения динамика.

Режим сбрасывается на «телефонию / дуплекс» (= низкая пропускная способность) каждый раз. Для перезагрузки динамика требуется около 20 щелчков, (щелкнуть меню, отключить, снова подключить, выбрать режим, тест), и это, безусловно, слишком много кликов.

Как я могу сделать режим «A2DP» режимом по умолчанию, а сделать это постоянным образом?

Несколько иллюстраций экрана иллюстрируют.

После выбора этого меню, щелкнув значок Bluetooth на верхней панели в Unity ...

После настройки этого ...

... предпочтительный режим будет сброшен до этого после перезапуска / приостановки компьютера

    
задан knb 14.07.2013 в 11:04
источник

5 ответов

21

В /etc/bluetooth/audio.conf есть опция AutoConnect=true , которая хеширована.

sudo nano /etc/bluetooth/audio.conf

Удалите «#» в начале строки AutoConnect = true

Мне удалось включить эту опцию, удалив # и получив правильное соединение с моей гарнитурой bluetooth

Перезапустите службу bluetooth, чтобы изменения вступили в силу:

sudo service bluetooth restart
    
ответ дан Joe 21.12.2014 в 14:12
источник
21

Добавьте следующую строку в /etc/bluetooth/audio.conf :

[General]
Disable=Headset

, а затем выполните следующую команду:

sudo service bluetooth restart

Тема: (Natty) Подключить только профиль A2DP для гарнитуры bluetooth.

    
ответ дан amagnoni 11.02.2014 в 03:07
3

Для тех, кого интересует, я нашел в Ubuntu 16.04, есть небольшая разница в ответе:

sudo gedit /etc/bluetooth/main.conf

И обновите следующую строку

#AutoEnable=false

к

AutoEnable=true

Далее

sudo service bluetooth restart

Для меня это по умолчанию означает, что аудиофайл подключен к A2DP Sink при подключении аудиоустройства Bluetooth.     

ответ дан N.AbdullaSunderland 02.09.2017 в 13:01
3

Я использую Gnome3, и через некоторое время моя гарнитура больше не подключается к A2DP. Мне пришлось остановить Gnome, создав демона pulseaudio, создав файл /var/lib/gdm3/.config/pulse/client.conf (от имени root) и добавив к нему следующие строки:

autospawn = no
daemon-binary = /bin/true

Затем установите владельца в gdm:

sudo chown gdm:gdm /var/lib/gdm3/.config/pulse/client.conf

Затем откройте / запустите или найдите процесс pulseaudio, запущенный в качестве пользователя gdm с ps aux | grep pulse

Вывод

(Trimmed) выглядит следующим образом:

gdm       2943  10616 ?        S<l  Sep01   0:00 /usr/bin/pulseaudio..

Затем запустите процесс с kill <pid> , который для меня был 2943

Запустив bluetoothctl и снова подключившись, я смог запустить pacmd list-cards и найти свое устройство index: 2 и перейти на a2dp_sink с pacmd set-card-profile 2 a2dp_sink .

Наконец, снова работаем!

    
ответ дан Dylan 30.08.2017 в 07:23
0

Для автоматического переключения звука на устройство Bluetooth A2DP при подключении в Ubuntu 14.04 я выполнил инструкции Ссылка , и это сработало отлично.

Измените /etc/pulse/default.pa , чтобы автоматически переключать пульс-приемник в Bluez:

.ifexists module-bluetooth-discover.so
load-module module-bluetooth-discover
load-module module-switch-on-connect  # Add this
.endif

Изменить /etc/bluetooth/audio.conf для автоматического выбора профиля A2DP (вместо HSP / HFP):

[General]
Disable=Headset # Add this

Применить изменения:

pulseaudio -k # Restarts pulseaudio
sudo service bluetooth restart # Restarts BT

Дополнительная информация: Ссылка

    
ответ дан Caumons 11.10.2017 в 10:35