Как отключить гостевую сессию?

182

Как отключить гостевую сессию в Ubuntu 11.10 или новее? Я не хочу, чтобы люди могли использовать мой компьютер, не используя пароль для входа!

    
задан Jeremy Bicha 22.09.2011 в 15:45
источник

12 ответов

118

Обновлено: 2016-авг.

Для Ubuntu 16.04 LTS (15.10 или новее)

Адаптировано из: LightDM Ubuntu Wiki - Конфигурация

  • Системные конфигурационные файлы в /usr/share/lightdm/ являются не предназначенными для редактирования пользователем. Вместо этого пользователи должны использовать: /etc/lightdm/
  • В новых версиях LightDM (Ubuntu 15.10 или более поздних) используйте [Seat:*] вместо [SeatDefaults]

Просто запустите это (один раз) в терминале:

sudo sh -c 'printf "[Seat:*]\nallow-guest=false\n" >/etc/lightdm/lightdm.conf.d/50-no-guest.conf'

Чтобы отменить (восстановить параметр Guest), удалить созданный файл :

sudo rm /etc/lightdm/lightdm.conf.d/50-no-guest.conf

Для Ubuntu 14.04 LTS (до 15.04)

Адаптировано из: Ubuntu Forums - расположение конфигурационных файлов lightdm в 14.04

Просто запустите это (один раз) в терминале:

sudo sh -c 'printf "[SeatDefaults]\nallow-guest=false\n" >/usr/share/lightdm/lightdm.conf.d/50-no-guest.conf'

У вас больше не будет параметра «Гость» в качестве логина при следующем входе в систему.

Чтобы отменить (восстановить параметр Guest), удалить созданный файл :

sudo rm /usr/share/lightdm/lightdm.conf.d/50-no-guest.conf

Для Ubuntu 12.04 LTS (до 13.10)

Самый простой метод.

Просто запустите это (один раз) в терминале:

sudo /usr/lib/lightdm/lightdm-set-defaults -l false

У вас больше не будет параметра «Гость» в качестве логина при следующем входе в систему.

  • Это просто добавляет allow-guest=false к /etc/lightdm/lightdm.conf .

  • Должно работать от 11.10 и далее (поскольку они используют LightDM ).

Отменить (восстановить параметр Guest):

sudo /usr/lib/lightdm/lightdm-set-defaults -l true
    
ответ дан david6 27.07.2012 в 23:38
источник
115

Only use this method if you are using Ubuntu Desktop. If you are using another flavour such as Xubuntu or Lubuntu please refer to this answer instead.

Если вы используете LightDM по умолчанию, отредактируйте /etc/lightdm/lightdm.conf , чтобы он выглядел следующим образом:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
allow-guest=false

Если вы используете GDM (который был по умолчанию в предыдущих выпусках Ubuntu), удалите gdm-guest-session .

Для Ubuntu 13.10 до 14.10 файл переместился на /etc/lightdm/lightdm.conf.d/50-unity-greeter.conf

Для Ubuntu 14.10 или выше файл переместился в /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf

    
ответ дан Jeremy Bicha 22.09.2011 в 15:48
источник
24

Введите это в терминал

gksu gedit /etc/lightdm/lightdm.conf

Вы увидите следующее:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu

Добавьте allow-guest=false к концу, чтобы ваш конечный результат выглядел следующим образом:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
allow-guest=false

Сохраните документ и закройте текстовый редактор.

Вернитесь в терминал, перезапустите диспетчер дисплеев. (Это закончит графический сеанс входа в систему, сразу же покинув все запущенные в нем программы, поэтому убедитесь, что ваша работа - как и любые открытые документы - сохранена сперва!)

sudo restart lightdm

С завершением графического входа в систему вы вернетесь на экран входа в систему, где вы заметите, что гостевая учетная запись отключена.

Вот и все - учетная запись гостя больше не используется.

    
ответ дан sarveshlad 25.10.2011 в 01:08
источник
17

Вы можете сделать это, используя Ubuntu Tweak .

Чтобы установить его, используйте следующие команды:

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

После установки перейдите в Твики> Настройки входа и отключите учетную запись гостя.

    
ответ дан Eliran Malka 21.10.2012 в 17:54
источник
11

Просто запустите

gksudo gedit /etc/lightdm/lightdm.conf

Добавьте следующую строку

allow-guest=false

Затем (это немедленно выйдет из системы, оставив любые программы, запущенные в графическом сеансе, поэтому сначала сохраните свою работу):

sudo restart lightdm
    
ответ дан LnxSlck 27.07.2012 в 16:42
источник
4

Как отключить эту опцию в будущем

Я только столкнулся с той же проблемой в моей новой установке trusty / 14.04. К моему удивлению, я не смог найти папку lightdm.conf.d внутри /etc/lightdm/ только users.conf .

Исследование

$ find / -iname *lightdm* 2>/dev/null | grep -v /mnt | grep -v /media | grep -v /home
[...]
/usr/share/lightdm/lightdm.conf.d
[...]
Ага, вот ты где. Что там?

$ ls -1 /usr/share/lightdm/lightdm.conf.d/
50-greeter-wrapper.conf
50-guest-wrapper.conf
50-ubuntu.conf
50-unity-greeter.conf
50-xserver-command.conf

Хорошо, что там?

$ cat /usr/share/lightdm/lightdm.conf.d/*
[SeatDefaults]
greeter-wrapper=/usr/lib/lightdm/lightdm-greeter-session
[SeatDefaults]
guest-wrapper=/usr/lib/lightdm/lightdm-guest-session
[SeatDefaults]
user-session=ubuntu
[SeatDefaults]
greeter-session=unity-greeter
[SeatDefaults]
# Dump core
xserver-command=X -core

Заключение

Мы находим кучу конфигурационных файлов, похожих на формат INI , следуя схеме именования 50-${some-descriptive-name}.conf и настраивая ключи для раздела [SeatDefaults] .

Мы не будем редактировать какие-либо из этих файлов , поскольку они предназначены для управления диспетчером пакетов, но теперь мы должны добавить и управлять нашим пользовательские биты конфигурации до /etc .

Решение

Учитывая вышеизложенное, lightdm является диспетчером отображения, а файлы конфигурации выглядят как выше. Следующее решение должно работать:

  1. Создайте отсутствующие каталоги:

    $ sudo mkdir -p /etc/lightdm/lightdm.conf.d
    
  2. Добавьте пользовательский файл конфигурации, выполнив:

    $ sudo nano /etc/lightdm/lightdm.conf.d/50-disable-guest-session.conf
    

    и вставьте следующие строки:

    [SeatDefaults]
    allow-guest=false
    

    Затем сохраните ( Ctrl + O ) и закройте ( Ctrl + X ).

  3. Теперь выйдите из системы и перейдите на виртуальный терминал ( Ctrl + Alt + F1 ), затем запустите:

    $ sudo service lightdm restart
    

    Теперь параметр гостевой сессии должен исчезнуть. Если что-то не работает правильно, вы теперь знаете, где хранится конфигурация по умолчанию и что вы ее не изменили.

Дальнейшее чтение

ответ дан LiveWireBT 16.03.2014 в 02:32
источник
3

Для Ubuntu 13.10 добавьте

allow-guest=false

в файл /etc/lightdm/lightdm.conf.d/10-ubuntu.conf .

    
ответ дан uahummer 20.10.2013 в 13:27
источник
3

13.04 и более поздние

  1. Выполните эту команду в терминале

    sudo /usr/lib/lightdm/lightdm-set-defaults -l false
    
  2. Перезагрузите компьютер или перезапустите lightdm со следующей командой (это немедленно выйдет из системы, сохранит ваши данные)

    sudo restart lightdm
    

По-видимому, он работает в 13.10 (не может проверить себя, но есть комментарий здесь ).

Я использую 13.04, и все это добавляет allow-guest=false к /etc/lightdm/lightdm.conf , но в 13.10 может быть иначе.

Первоначально david6 отсюда: Ссылка

    
ответ дан kiri 21.10.2013 в 07:33
источник
2

Установите ubuntu-tweak, перейдите на вкладку настройки, выключите гостевую кнопку и перезагрузитесь. Это оно!

Можно легко найти терминал, но если возникнет необходимость включить гостевую учетную запись, вам придется снова посетить эту страницу и увидеть инструкции (или, вернее, отменить). Это преимущество GUI-объекта ... он легко запоминает его.

    
ответ дан tadatma 27.09.2012 в 17:33
источник
2

Измените allow-guest=true на 'false' в /etc/lightdm/lightdm.conf

Затем вы можете перезагрузить или перезапустить службу в терминале:

sudo restart lightdm

Предполагая, что вы используете lightdm , который standard в 11.10.

    
ответ дан filescraps 21.10.2011 в 10:42
источник
0

Я в том же случае, файл /etc/lightdm/lightdm.conf не существует в UBUNTU 13.10.

Я пытаюсь создать файл /etc/lightdm/lightdm.conf с этой строкой allow-guest=false и CRASH, система не запускается должным образом, только консольный режим ...

Я пытаюсь отредактировать файл /etc/lightdm/lightdm.conf.d/10-ubuntu.conf и правильно работает.

Отредактируйте файл

sudo vim /etc/lightdm/lightdm.conf.d/10-ubuntu.conf

И введите нужные строки

# to disable guest login
allow-guest=false
# to enable user login manually
greeter-show-manual-login=true

И последний, перезагрузите систему

sudo reboot

Я думаю, что это отлично работает, если вы перезапустите только ligthgdm

sudo service lightdm restart
    
ответ дан Foncu 23.10.2013 в 14:05
источник
0

Открыть терминал

gksudo gedit /etc/lightdm/lightdm.conf

Добавьте следующую строку

allow-guest=false

Сохранить и выйти из файла.

    
ответ дан scouser73 21.10.2013 в 07:29
источник

Ознакомьтесь с другими вопросами по меткам