Как отключить автоматическую установку удаленного принтера?

47

В Raring каждый раз, когда я подключаюсь к сети, чашки автоматически устанавливают все принтеры в сети, несколько раз.

Кроме того, я время от времени подключаю USB-принтер к ноутбуку. Несмотря на то, что принтер уже настроен, в список добавлен другой принтер.

Я хочу отключить эту функцию и разрешить только ручную установку принтеров. Как мне это сделать?

    
задан To Do 13.09.2013 в 14:44
источник

8 ответов

48

Я только что обнаружил, возможно, оптимальное решение этого беспорядка. Существует сервис под названием «чашки», который, по-видимому, отвечает за выход в сеть и поиск всех принтеров, которые он может найти и установить для вас (gee-thanks --NOT). Поскольку это задание Upstart, вы можете остановить службу с помощью:

sudo service cups-browsed stop

Еще лучше, вы можете запретить запуск службы снова, добавив простой текстовый файл в /etc/init , который содержит одно слово manual . Файл должен быть назван cups-browsed.override

Итак, просто запустите gedit с помощью

gksudo gedit /etc/init/cups-browsed.override

поместите manual в первую и единственную строку и сохраните файл.

При следующей перезагрузке служба не будет перезапущена. Однако вам не нужно перезагружаться, если вы уже остановили службу. После того, как вы поместили этот файл в / etc / init, услугу можно запустить только вручную (если и когда вам нужно / нужно), используя:

sudo service cups-browsed start
-or-
sudo service cups-browsed stop'

Я тестировал это за одну перезагрузку. Печать все еще прекрасна, и до сих пор я не получаю несколько сотен принтеров после перезагрузки. Только те, которые я установил вручную, отображаются.

    
ответ дан Steve Besch 31.10.2013 в 17:59
источник
20

В /etc/cups/cups-browsed.conf , установите директиву:

BrowseProtocols none

Затем запустите service cups-browsed restart и service cups restart . Не должно быть видимых принтеров, кроме тех, которые вы добавили сами.

    
ответ дан Maciej Woloszyn 05.12.2014 в 13:44
6

Чтобы отключить его, просто откройте терминал Ctrl + Alt + T и введите

 sudo cupsctl --no-remote-printers

или отредактировать

 /etc/cups/cupsd.conf

и установите

Browsing Off

Это решение было найдено здесь

Некоторым более новым Ubuntus (15.04 и выше) может понадобиться эта команда:

sudo cupsctl --no-share-printers
    
ответ дан SimplySimon 13.09.2013 в 15:49
5

Как уже упоминалось ранее, это делается теперь в библиотеках чашек на стороне клиента (т.е. libcups.so, с которыми связаны приложения GNOME и KDE), а не на сервере cupsd. Поэтому изменение настроек «Обзор» на сервере чашек не будет работать.

$ ldd /usr/lib/x86_64-linux-gnu/libcups.so.2
...
libavahi-common.so.3 => /usr/lib/x86_64-linux-gnu/libavahi-common.so.3
libavahi-client.so.3 => /usr/lib/x86_64-linux-gnu/libavahi-client.so.3
...

IE это поведение (показывая удаленные принтеры в диалоговом окне «Печать»), даже если вы отключите локальный сервер чашек. Вы можете отключить его, отключив службу avahi , но это отключит все связанные функции zeroconf / mdns.

Однако есть хотя бы способ отключить большинство функций avahi (включая добавление удаленных принтеров в клиенты CUPS), сохраняя при этом функциональность DNS (например, при поиске foo.local -строчных имен хостов):

отредактируйте /etc/avahi/avahi-daemon.conf и в разделе [server] добавьте enable-dbus=no , затем перезапустите службу avahi-daemon.

    
ответ дан John McP 05.08.2015 в 11:20
4

Теперь в клиентских библиотеках чашек также есть список сетевых принтеров Avahi (который реализует протокол, известный по-разному как zeroconf или Bonjour или mdns или dns-sd). В старых версиях чашек это делалось только сервером чашек.

Вы можете видеть, что транслируется в вашей сети с помощью команды оболочки, например avahi-browse -a | grep Printer

Вы можете отключить avahi с sudo service avahi-daemon stop , но это остановит установку all на основе zeroconf, а не только на принтеры.

    
ответ дан John McP 27.02.2014 в 03:31
1

Это довольно просто, чтобы остановить.

  1. Удалите ненужные принтеры. Тогда:

    sudo nano /etc/cups/cups-browsed.conf
    
  2. Измените эту строку: BrowseRemoteProtocols dnssd cups (или whaterver после этого) на none, чтобы она читала: BrowseRemoteProtocols none .

  3. Затем сохраните файл и перезагрузитесь.

Решил проблему для меня.

    
ответ дан Bas Heijermans 16.11.2015 в 16:41
0

Try:

  1. Открыть http://localhost:631/admin/ → Изменить файл конфигурации или Изменить /etc/cups/cupsd.conf

  2. Изменить:

    # Show shared printers on the local network.
    Browsing Off
    BrowseLocalProtocols none
    

Ссылка: cupsd.conf: BrowseLocalProtocols

    
ответ дан user.dz 20.03.2014 в 13:08
0

Найденное решение, если вы отключите bonjour в HP (возможно, другие принтеры тоже), обнаружение тайного принтера является проблемой прошлого.

    
ответ дан Bas Heijermans 26.01.2018 в 15:27