Установить gcc на Ubuntu 12.04 LTS

40

Когда я пытаюсь установить gcc на сервер Ubuntu 12.04 LTS с apt-get install gcc , я получаю следующую ошибку:

The following packages have unmet dependencies:
 gcc : Depends: cpp (>= 4:4.6.1-2ubuntu5) but it is not going to be installed
       Depends: gcc-4.6 (>= 4.6.1-1) but it is not going to be installed
       Recommends: libc6-dev but it is not going to be installed or
                   libc-dev

Когда я углубляюсь (т. е. пытаюсь apt-get install gcc-4.6 ), я получаю:

 gcc-4.6 : Depends: gcc-4.6-base (= 4.6.1-9ubuntu3) but 4.6.3-1ubuntu5 is to be installed
           Depends: cpp-4.6 (= 4.6.1-9ubuntu3) but it is not going to be installed
           Depends: libgomp1 (>= 4.6.1-9ubuntu3) but it is not going to be installed
           Depends: libquadmath0 (>= 4.6.1-9ubuntu3) but it is not going to be installed
           Recommends: libc6-dev (>= 2.13-0ubuntu6) but it is not going to be installed

Поэтому, когда я пытаюсь установить gcc-4.6=4.6.1-9ubuntu3 , я получаю список из 366 пакетов для удаления (включая, например, apt ). Это безумие.

Это, по существу, ванильная установка Ubuntu 12.04 LTS Server (т.е. я установил nginx, python-flup, python-yaml, rsync, python-pkg-resources, lsof, fontconfig, iptables, ufw, scons и grc).

Мне очень удивительно, что я не могу установить gcc, поэтому я немного смущен тем, почему попытка установки gcc не выполняется. Единственным очевидным исправлением, похоже, будет удаление 366 пакетов, многие из которых являются центральными для работы Ubuntu.

Что-то не складывается, и я буду очень благодарен за помощь.

РЕДАКТИРОВАТЬ . Вышеупомянутые с последними пакетами, конечно, использовали apt-get update; apt-get upgrade перед тем, как это сделать. Извините, я должен был упомянуть об этом.

    
задан Brian M. Hunt 22.06.2012 в 02:49
источник

3 ответа

73

Есть метапакет с именем build-essential , который должен установить компилятор и кучу связанных / необходимых пакетов:

sudo apt-get install build-essential

Предполагается, что сначала sudo apt-get update будет звуковым, это обновит списки пакетов, и все версии должны хорошо соответствовать.

Это, однако, если вы не изменили свой файл /etc/apt/sources.list вручную. Если это так, то, возможно, некоторые из внесенных вами изменений или добавленные вами репозитории содержат конфликтующие пакеты, которые вызывают проблемы, которые вы видите. Если это так, посмотрите файл и исправьте неприятные записи. Конечно, если вы хотите помочь, вы можете опубликовать свой файл sources.list (или любые фрагменты в /etc/apt/sources.list.d ), и, возможно, кто-то может помочь вам исправить их.

    
ответ дан roadmr 22.06.2012 в 03:08
источник
4

Постарайтесь идти глубже:

sudo apt-get update
sudo apt-get install gcc-4.6-base cpp-4.6 libgomp1 libquadmath0 libc6-dev
    
ответ дан David M. Sousa 22.06.2012 в 02:58
-1

Сначала напишите команду:

sudo apt-get update.

Затем попробуйте:

sudo apt-get install gcc

Я сделал это, и это сработало! Вы также должны попробовать.

Если он не работает, то:

sudo apt-get install build-essential

Тогда попробуйте. Я надеюсь, что это сработает!

    
ответ дан Master Programmer 01.10.2015 в 12:48