Создайте OpenSSL из источника, чтобы иметь расширение TLS «heartbeat» (id = 15) в Apache

0

Я создаю тестовую среду для уязвимости с помощью Heartbleed. Поэтому я делаю следующее:

  1. Перед запуском я настрою apache2 для работы с SSL ( Ссылка ). Я выполнил эту команду:

    openssl s_client -connect [server IP] -tlsextdebug 2>&1 | grep 'server extension "heartbeat" (id=15)' || echo safe
    

    Он возвращает этот TLS server extension "heartbeat" (id=15), len=1 == > используется биение сердечного ритма.

  2. Я выбираю сервер Ubuntu 12.04 как ОС

  3. Я удаляю Openssl и Apache2 полностью с apt-get remove --purge и apt-get autoremove
  4. Загружаю Openssl 1.0.1e отсюда: Ссылка
  5. Я создаю его со следующими командами:

    ./config --prefix=/usr/openssl --openssldir=/usr/openssl
    make
    make install
    
  6. Переустановите Apache2 с apt-get install apache2
  7. Выполняйте те же действия, что и для шага 0. Но на этот раз он возвращает safe , означает, что пульс не работает.

Как я могу заставить его работать сейчас?

Дополнительная информация: после создания Openssl из исходного кода, я проверяю, выполнив следующие команды:

openssl genrsa -out server.pem 1024
openssl req -new -x509 -key server.pem -subj /CN=localhost >> server.pem
openssl s_server -www

и протестировать Metasploit, это показывает, что эта версия Openssl имеет уязвимость.

Использование команды openssl version show 1.0.1e == > Версия, которую я построил

    
задан thanh dat tang 16.01.2017 в 14:52
источник

1 ответ

0

Ниже мой сценарий подготовит среду для демонстрации CVE-2014-0160.

Здесь я не могу опубликовать ссылку для скачивания, потому что у меня недостаточно репутации. Вам необходимо скачать openssl-1.0.1e.tar.gz, httpd-2.4.25.tar.gz, apr-1.5.2.tar.gz, apr-util-1.5.4.tar.gz, pcre-8.40. tar.gz в ваш домашний каталог.

#!/bin/sh

#Download installation files
cd ~
#Here I cannot post download link because I do not have enough reputation. 
#You need to download openssl-1.0.1e.tar.gz, httpd-2.4.25.tar.gz, apr-1.5.2.tar.gz, 
#apr-util-1.5.4.tar.gz, pcre-8.40.tar.gz into your home directory.

#Install compilers
yum -y groupinstall "Development Tools"

#Install pcre
cd ~
tar -zxvf pcre-8.40.tar.gz
cd pcre-8.40
./configure --prefix=/usr/local/pcre
make
make install

#Install openssl
cd ~
tar -zxvf openssl-1.0.1e.tar.gz
cd openssl-1.0.1e
./config     --prefix=/opt/openssl-1.0.1e     --openssldir=/opt/openssl-1.0.1e -fPIC -DOPENSSL_PIC
make
make install_sw

#Install openssl
cd ~
tar -zxvf openssl-1.0.1e.tar.gz
cd openssl-1.0.1e
./config     --prefix=/opt/openssl-1.0.1e     --openssldir=/opt/openssl-1.0.1e -fPIC -DOPENSSL_PIC
make
make install_sw

#Install httpd (using just installed opensll)
cd ~
tar -zxvf httpd-2.4.25.tar.gz
cd httpd-2.4.25/srclib/
tar zxvf ../../apr-1.5.2.tar.gz
ln -s apr-1.5.2/ apr
tar zxvf ../../apr-util-1.5.4.tar.gz
ln -s apr-util-1.5.4/ apr-util
cd ~
cd httpd-2.4.25
./configure     --prefix=/opt/httpd     --with-included-apr     --enable-ssl     --with-ssl=/opt/openssl-1.0.1e --enable-ssl-staticlib-deps     --enable-mods-static=ssl --with-pcre=/usr/local/pcre
make
make install

#Add configuration to use HTTPS (port 443)
cd ~
sed -i '/^#.*Include conf\/extra\/httpd-ssl.conf/s/^#//' /opt/httpd/conf/httpd.conf
sed -i '/^#.*LoadModule socache_shmcb_module modules\/mod_socache_shmcb.so/s/^#//' /opt/httpd/conf/httpd.conf

cd ~
openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /opt/httpd/conf/server.key -out /opt/httpd/conf/server.crt -subj "/C=JP/ST=/L=/O=/OU=/CN=192.168.122.137"

/opt/httpd/bin/apachectl start

iptables -F

#Start httpd on booting
chmod +x /etc/rc.d/rc.local
echo '/opt/httpd/bin/apachectl start' >> /etc/rc.local

#Remove downloaded files
cd ~
rm -rf ~/openssl-1.0.1*

rm -rf ~/httpd*

rm -rf ~/pcre*
    
ответ дан thanh dat tang 09.02.2017 в 06:19
источник