Должен ли я беспокоиться о «предупреждении: области контрольной суммы больше размера изображения. Неверная таблица таблицы? "При обновлении ядра?

6

Я только что выполнил команду sudo apt-get dist-upgrade , и это был результат:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed
  linux-headers-4.2.0-23 linux-headers-4.2.0-23-generic
  linux-image-4.2.0-23-generic linux-image-extra-4.2.0-23-generic
  linux-signed-image-4.2.0-23-generic
The following packages will be upgraded:
  linux-generic linux-headers-generic linux-image-generic linux-libc-dev
  linux-signed-generic linux-signed-image-generic
6 to upgrade, 5 to newly install, 0 to remove and 0 not to upgrade.
Need to get 67.1 MB of archives.
After this operation, 287 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu/ wily-updates/main linux-image-4.2.0-23-generic amd64 4.2.0-23.28 [17.3 MB]
Get:2 http://archive.ubuntu.com/ubuntu/ wily-updates/main linux-image-extra-4.2.0-23-generic amd64 4.2.0-23.28 [38.6 MB]
Get:3 http://archive.ubuntu.com/ubuntu/ wily-updates/main linux-generic amd64 4.2.0.23.25 [1,784 B]
Get:4 http://archive.ubuntu.com/ubuntu/ wily-updates/main linux-image-generic amd64 4.2.0.23.25 [2,418 B]
Get:5 http://archive.ubuntu.com/ubuntu/ wily-updates/main linux-signed-image-4.2.0-23-generic amd64 4.2.0-23.28 [3,998 B]
Get:6 http://archive.ubuntu.com/ubuntu/ wily-updates/main linux-signed-generic amd64 4.2.0.23.25 [1,816 B]
Get:7 http://archive.ubuntu.com/ubuntu/ wily-updates/main linux-signed-image-generic amd64 4.2.0.23.25 [2,456 B]
Get:8 http://archive.ubuntu.com/ubuntu/ wily-updates/main linux-headers-4.2.0-23 all 4.2.0-23.28 [9,595 kB]
Get:9 http://archive.ubuntu.com/ubuntu/ wily-updates/main linux-headers-4.2.0-23-generic amd64 4.2.0-23.28 [765 kB]
Get:10 http://archive.ubuntu.com/ubuntu/ wily-updates/main linux-headers-generic amd64 4.2.0.23.25 [2,390 B]
Get:11 http://archive.ubuntu.com/ubuntu/ wily-updates/main linux-libc-dev amd64 4.2.0-23.28 [817 kB]
Fetched 67.1 MB in 1min 34s (708 kB/s)                                         
Selecting previously unselected package linux-image-4.2.0-23-generic.
(Reading database ... 356003 files and directories currently installed.)
Preparing to unpack .../linux-image-4.2.0-23-generic_4.2.0-23.28_amd64.deb ...
Examining /etc/kernel/preinst.d/
run-parts: executing /etc/kernel/preinst.d/intel-microcode 4.2.0-23-generic /boot/vmlinuz-4.2.0-23-generic
Done.
Unpacking linux-image-4.2.0-23-generic (4.2.0-23.28) ...
Selecting previously unselected package linux-image-extra-4.2.0-23-generic.
Preparing to unpack .../linux-image-extra-4.2.0-23-generic_4.2.0-23.28_amd64.deb ...
Unpacking linux-image-extra-4.2.0-23-generic (4.2.0-23.28) ...
Preparing to unpack .../linux-generic_4.2.0.23.25_amd64.deb ...
Unpacking linux-generic (4.2.0.23.25) over (4.2.0.22.24) ...
Preparing to unpack .../linux-image-generic_4.2.0.23.25_amd64.deb ...
Unpacking linux-image-generic (4.2.0.23.25) over (4.2.0.22.24) ...
Selecting previously unselected package linux-signed-image-4.2.0-23-generic.
Preparing to unpack .../linux-signed-image-4.2.0-23-generic_4.2.0-23.28_amd64.deb ...
Unpacking linux-signed-image-4.2.0-23-generic (4.2.0-23.28) ...
Preparing to unpack .../linux-signed-generic_4.2.0.23.25_amd64.deb ...
Unpacking linux-signed-generic (4.2.0.23.25) over (4.2.0.22.24) ...
Preparing to unpack .../linux-signed-image-generic_4.2.0.23.25_amd64.deb ...
Unpacking linux-signed-image-generic (4.2.0.23.25) over (4.2.0.22.24) ...
Selecting previously unselected package linux-headers-4.2.0-23.
Preparing to unpack .../linux-headers-4.2.0-23_4.2.0-23.28_all.deb ...
Unpacking linux-headers-4.2.0-23 (4.2.0-23.28) ...
Selecting previously unselected package linux-headers-4.2.0-23-generic.
Preparing to unpack .../linux-headers-4.2.0-23-generic_4.2.0-23.28_amd64.deb ...
Unpacking linux-headers-4.2.0-23-generic (4.2.0-23.28) ...
Preparing to unpack .../linux-headers-generic_4.2.0.23.25_amd64.deb ...
Unpacking linux-headers-generic (4.2.0.23.25) over (4.2.0.22.24) ...
Preparing to unpack .../linux-libc-dev_4.2.0-23.28_amd64.deb ...
Unpacking linux-libc-dev:amd64 (4.2.0-23.28) over (4.2.0-22.27) ...
Setting up linux-image-4.2.0-23-generic (4.2.0-23.28) ...
Running depmod.
update-initramfs: deferring update (hook will be called later)
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.2.0-23-generic /boot/vmlinuz-4.2.0-23-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.2.0-23-generic /boot/vmlinuz-4.2.0-23-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.2.0-23-generic /boot/vmlinuz-4.2.0-23-generic
update-initramfs: Generating /boot/initrd.img-4.2.0-23-generic
run-parts: executing /etc/kernel/postinst.d/unattended-upgrades 4.2.0-23-generic /boot/vmlinuz-4.2.0-23-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 4.2.0-23-generic /boot/vmlinuz-4.2.0-23-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 4.2.0-23-generic /boot/vmlinuz-4.2.0-23-generic
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.2.0-23-generic
Found initrd image: /boot/initrd.img-4.2.0-23-generic
Found linux image: /boot/vmlinuz-4.2.0-22-generic
Found initrd image: /boot/initrd.img-4.2.0-22-generic
Found linux image: /boot/vmlinuz-4.2.0-21-generic
Found initrd image: /boot/initrd.img-4.2.0-21-generic
Adding boot menu entry for EFI firmware configuration
done
Setting up linux-image-extra-4.2.0-23-generic (4.2.0-23.28) ...
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.2.0-23-generic /boot/vmlinuz-4.2.0-23-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.2.0-23-generic /boot/vmlinuz-4.2.0-23-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.2.0-23-generic /boot/vmlinuz-4.2.0-23-generic
update-initramfs: Generating /boot/initrd.img-4.2.0-23-generic
run-parts: executing /etc/kernel/postinst.d/unattended-upgrades 4.2.0-23-generic /boot/vmlinuz-4.2.0-23-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 4.2.0-23-generic /boot/vmlinuz-4.2.0-23-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 4.2.0-23-generic /boot/vmlinuz-4.2.0-23-generic
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.2.0-23-generic
Found initrd image: /boot/initrd.img-4.2.0-23-generic
Found linux image: /boot/vmlinuz-4.2.0-22-generic
Found initrd image: /boot/initrd.img-4.2.0-22-generic
Found linux image: /boot/vmlinuz-4.2.0-21-generic
Found initrd image: /boot/initrd.img-4.2.0-21-generic
Adding boot menu entry for EFI firmware configuration
done
Setting up linux-image-generic (4.2.0.23.25) ...
Setting up linux-headers-4.2.0-23 (4.2.0-23.28) ...
Setting up linux-headers-4.2.0-23-generic (4.2.0-23.28) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 4.2.0-23-generic /boot/vmlinuz-4.2.0-23-generic
Setting up linux-headers-generic (4.2.0.23.25) ...
Setting up linux-generic (4.2.0.23.25) ...
Setting up linux-signed-image-4.2.0-23-generic (4.2.0-23.28) ...
warning: file-aligned section .text extends beyond end of file
warning: checksum areas are greater than image size. Invalid section table?
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.2.0-23-generic
Found initrd image: /boot/initrd.img-4.2.0-23-generic
Found linux image: /boot/vmlinuz-4.2.0-22-generic
Found initrd image: /boot/initrd.img-4.2.0-22-generic
Found linux image: /boot/vmlinuz-4.2.0-21-generic
Found initrd image: /boot/initrd.img-4.2.0-21-generic
Adding boot menu entry for EFI firmware configuration
done
Setting up linux-signed-image-generic (4.2.0.23.25) ...
Setting up linux-signed-generic (4.2.0.23.25) ...
Setting up linux-libc-dev:amd64 (4.2.0-23.28) ...

Вы можете заметить, что некоторые строки читаются:

warning: file-aligned section .text extends beyond end of file
warning: checksum areas are greater than image size. Invalid section table?

Что именно это означает и это все, о чем я должен беспокоиться?

Информация о ОС:

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 15.10
Release:    15.10
Codename:   wily
Flavour: GNOME
GNOME Version: 3.18
    
задан Paranoid Panda 05.01.2016 в 19:22
источник

1 ответ

5

Я нашел страницу Ссылка , в которой упоминается это предупреждение:

  

[...]

warning: file-aligned section .text extends beyond end of file
warning: checksum areas are greater than image size. Invalid section table?
     

[...]

     

В этом примере показаны два предупреждения. Я не претендую на то, чтобы полностью их понять, но они, похоже, не принесут никакого вреда - по крайней мере, двоичные файлы ядра Linux, которые я подписал, которые подготовили эти предупреждения, отлично работали. (Такие предупреждения, похоже, менее распространены в 2015 году, чем они были пару лет назад.).

     

[...]

Если этого автора не беспокоит, то я не являюсь.

    
ответ дан siepo 06.01.2016 в 16:54