Как установить последние драйверы видео ATI Catalyst в Ubuntu 12.10 Quantal?

6

Есть другие темы, связанные с этим вопросом для Ubuntu 12.04, однако ОНИ НЕ ПРИМЕНЯЮТСЯ до 12.10. Это не дубликат другого потока, если указанный поток не отвечает на заданный вопрос.

    
задан Chris Bauer 22.10.2012 в 03:36
источник

4 ответа

4

Для целей этого вопроса: Catalyst = fglrx = проприетарный драйвер дисплея AMD / ATI

Большинство проблем возникают из-за того, что:
1. Ubuntu перешел на более новые версии драйверов, которые не поддерживают некоторые старые чипы ATI / AMD
2. Ubuntu перешел на более новые версии Xorg

Симптомы:
№ 1 - "не поддерживается" ошибки / Жокей не обнаруживает проприетарные драйверы, действительные для установки
№ 2 - некоторые старые версии ATI / AMD Catalyst не будут устанавливать

Что все сводится к:
Ваш чип больше не поддерживается новейшими драйверами отображения драйверов ATI / AMD (будь то с помощью ручной установки или из репозиториев Ubuntu)

Решение:
Проверьте, какая последняя версия драйвера поддерживает ваш чип, а затем выполните установку соответствующим образом.
Ссылка (может быть немного устаревшим)
или
введите данные вашей видеокарты здесь:
Ссылка
используйте команду терминала для отображения информации о вашей графике

lspci | grep VGA

Если последняя версия для вас - 12.6 = > действуйте согласно Ссылка

Чипы, которые обозначены как "устаревшие" (не поддерживаются для последних версий Catalyst):
Попробуйте PPA, перечисленные здесь Как установить старые драйверы AMD Catalyst 12.4 на Ubuntu 12.10? Вы, скорее всего, получите Catalyst 12.6

Чипы, поддерживаемые ARE в 12.10 / последними драйверами Catalyst:
Установка должна выполняться согласно Что такое правильный способ установки проприетарных видеоадаптеров ATI Catalyst (fglrx) непосредственно из AMD?

    
ответ дан Bucic 25.10.2012 в 13:08
1

Вот последняя версия Ati Catalyst 12.11 (beta) и 12.10 (stable), которая только что была выпущена, вы можете найти здесь: Ссылка надеюсь, что это сработает.     

ответ дан Baltazar Blake 25.10.2012 в 12:12
1

Последний катализатор ATI для Ubuntu 12.10 Я знаю об этом: Драйвер AMD Catalyst 12,9

Сначала Удалите текущий драйвер AMD с помощью следующих команд:

sudo sh /usr/share/ati/fglrx-uninstall.sh 
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx  

Ручная установка:

Чтобы установить AMD Catalyst 12.9 в Ubuntu 12.10 / 12.04 / 11.10, выполните следующие команды с терминала:

sudo apt-get install unzip
cd /tmp && wget -O amd-12.9-9.00-EDG_Direct.zip http://www2.ati.com/drivers/embedded/9.00-120815a-146426C-EDG_Direct.zip
unzip amd-12.9-9.00-EDG_Direct.zip
chmod +x amd-driver-installer-9.00-x86.x86_64.run 
sudo sh amd-driver-installer-9.00-x86.x86_64.run

Затем, после завершения установки, запустите эту команду:

sudo aticonfig --initial -f 

Затем перезагрузитесь.

Примечание. PPA пока не обновлен, но скоро будет обновлен драйвер. Чтобы установить драйвер, предоставленный xorg-edgers , откройте терминал и запустите следующие команды:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install fglrx-installer
    
ответ дан Baltazar Blake 22.10.2012 в 05:23
0

Если вы хотите обновить драйверы собственных драйверов ATI / AMD Catalyst до последней версии или хотите попробовать новейшие драйверы AMD Catalyst BETA, посмотрите:

Фан-клуб - установка Ubuntu AMD Catalyst

  • Приложение автоматически обнаруживает ваше графическое оборудование ATI / AMD и выбирает лучшие параметры драйвера для установки.
  • Это приложение загружает, создает DEB-пакеты и устанавливает новейшие драйверы дисплея AMD Catalyst ™ для Ubuntu 32bit / 64bit.
  • Вы также можете установить новейший дисплей AMD Catalyst ™ Драйверы BETA, а также проприетарный дисплей Legacy AMD Catalyst ™ Драйверы, если ваше оборудование поддерживается.
ответ дан christiaan_ 07.03.2013 в 22:26