Как настроить Awesome WM с сервисами GNOME на произвольном Ubuntu?

6

tl; dr Существует ли общее руководство по настройке GNOME фоновых служб для работы с Awesome WM на любом Ubuntu?

официальное руководство , похоже, не обновлялось с Ubuntu 11.10. Другое руководство немного более актуально, но после обновления до 12.10

  1. панели GNOME сверху и снизу первого монитора. Их там не должно быть.
  2. Удивительное фоновое изображение WM.
  3. Удивительные панели на втором мониторе.
  4. Awesome control work ( Mod4 + число, чтобы перейти к тегу и т. д.).

После обновления до 13.04 сегодня это еще хуже:

  1. панели GNOME сверху и снизу первого монитора. Все еще не должно быть.
  2. На втором мониторе нет панелей.
  3. Удивительное фоновое изображение WM.
  4. feh при входе в систему, даже если оно установлено. Извините, не могу скопировать его здесь, так как я не могу воспроизвести (см. Ниже).
  5. Windows размещаются в X = 0 и Y = что-то вроде -10 (полосы заголовка окна около 90% на экране). Это означает, что я не могу получить доступ к меню на верхней панели, не закрывая все открытые приложения (поскольку их нельзя перемещать путем перетаскивания с помощью Mod4 или Meta ) .
  6. Некоторые сочетания клавиш GNOME работают ( Ctrl + Meta + Del , Ctrl + Мета + t ), но не другие ( Meta + F1 ).
  7. Нет Удивительные функции управления клавиатурой или мышью ( Mod4 + число, Mod4 + Введите , Mod4 + мышь перетащить).

Баллы 3 и 4 произошли только в первый раз после перезагрузки в 13.04; при втором входе я получаю фоновое изображение Ubuntu и сообщение об ошибке feh .

команда Я собрал вместе, чтобы настроить «Awesome GNOME» на основе руководства ( переформатирован для удобства чтения):

sudo sh -c '
apt-get install awesome awesome-extra gnome-session-fallback notification-daemon && \
printf "%s\n" "[Desktop Entry]" "Version=1.0" "Type=Application" "Name=awesome" "TryExec=awesome" "Exec=awesome" | tee /usr/share/applications/awesome.desktop && \
printf "%s\n" "[Desktop Entry]" "Name=Gnome with Awesome" "Comment=Gnome with Awesome as window manager" "TryExec=gnome-session" "Exec=gnome-session --session=awesome" "Type=Application" | tee /usr/share/xsessions/gnome-awesome.desktop && \
printf "%s\n" "[GNOME Session]" "Name=Awesome" "RequiredComponents=gnome-panel;gnome-settings-daemon;" "RequiredProviders=windowmanager;notifications;" "DefaultProvider-windowmanager=awesome" "DefaultProvider-notifications=notification-daemon" | tee /usr/share/gnome-session/sessions/awesome.session'

@ Ответ RolandSommer фиксировал большинство проблем. Тем временем я работал над сбоем комментируя все записи awful.util.spawn .     

задан l0b0 26.04.2013 в 17:23
источник

2 ответа

5

У вас есть gnome-панель в качестве требования в описании сеанса, поэтому вы действительно запрашиваете, чтобы панели были там.

Помимо требований gnome-panel, я использую ту же самую настройку в Ubuntu 13.04, и она отлично работает.

Измените

RequiredComponents=gnome-panel;gnome-settings-daemon;

к

RequiredComponents=gnome-settings-daemon;

, и вы настроены.

    
ответ дан Roland Sommer 16.05.2013 в 21:50
источник
0

О сообщении об ошибке feh: Попробуйте изменить theme.wallpaper_cmd в вашей теме.lua на {""}. Услуги Gnome будут устанавливать обои для вас без какой-либо помощи (по крайней мере, он работает в 12.10)

    
ответ дан dlussky 24.05.2013 в 16:03