Как отключить Ctrl + Q для всех приложений (в системе)?

47

Многие приложения, такие как Firefox, Chrome и т. д., закрываются, когда я случайно нажимаю Ctrl + Q вместо Ctrl + W из-за близости клавиш Q и W на клавиатуре. Есть ли способ, по которому этот ярлык можно удалить или сбросить на основе всей системы?

    
задан Khaja Minhajuddin 11.08.2010 в 08:01
источник

7 ответов

70

Лучший способ - отключить настройку клавиатуры в вашем конкретном приложении. Для Firefox есть расширение keyconfig . Это позволяет вам изменять настройки клавиатуры.

Если вы хотите отключить Ctrl + Q для всей вашей системы, я бы предложил создать новую настройку:

  1. Перейдите в раздел Система - > Предпочтения - > Настройки клавиатуры
  2. Нажмите Добавить
  3. Дайте ему имя, например поддельный параметр , и введите команду /bin/false as. Примените свои изменения.
  4. Нажмите « Отключено » и нажмите Ctrl + Q .

Теперь у вас должна быть новая запись с вашим прикладным именем и настройками клавиатуры. Каждый раз, когда вы нажимаете Ctrl + Q , ваша система будет запускать команду /bin/false , которая в основном ничего не делает. Таким образом, это является обходным путем для отключения настройки.

    
ответ дан qbi 11.08.2010 в 10:14
источник
3

Если Ctrl + Q закрывает окно настроек клавиатуры, как и для меня, установите ярлык для другого значения, закройте окно и дождитесь появления обновленного ярлыка где-то в ~/.gconf/desktop/gnome/keybindings/* . Откройте этот файл и отредактируйте stringvalue этой команды, чтобы прочитать <Primary>q . Затем перезагрузите компьютер. Это работало на меня, а не на принятый ответ.

    
ответ дан Fluffy 12.02.2013 в 21:45
3

Вероятно, добавление ярлыка в System - > Предпочтения - > Ярлыки клавиш и «отключение» должны сделать трюк.

    
ответ дан mariachris 11.08.2010 в 09:11
2

Вот версия командной строки уже поставляемой версии GUI. В некоторой системе Ctrl + Q закроет окно ввода ускорителя без установки ярлыка, поэтому это может понадобиться:

gconftool-2 --type string --set /desktop/gnome/keybindings/inhibit_ctrl_Q/name "Inhibit Ctrl+Q"
gconftool-2 --type string --set /desktop/gnome/keybindings/inhibit_ctrl_Q/action /bin/false
gconftool-2 --type string --set /desktop/gnome/keybindings/inhibit_ctrl_Q/binding "<Primary>q"

Обратите внимание, что это решение для gnome-2 / Unity. Аналогичное решение должно быть возможно с помощью gsettings для gnome-3.

    
ответ дан fuzzyBSc 29.07.2014 в 10:15
1

Вы можете перейти к System- > Preferences- > Сочетания клавиш и назначить эту комбинацию неиспользуемому действию. Например, я назначил CTRL + Q для переключения в рабочее пространство 12 (Нет, у меня нет 12 рабочих пространств).

В результате эта системная настройка переопределяет одно приложение, а CTRL + Q больше не закрывает firefox (вероятно, комбо никогда не доходит до Firefox). Он просто ничего не делает.

    
ответ дан Javier Rivera 11.08.2010 в 10:52
1

В Linux с Firefox Quantum в настоящее время существует ошибка , которая предотвращает изменение расширений и явной конфигурации встроенный ярлык, такой как ctrl-Q. Обходной путь состоит в том, чтобы заблокировать его на уровне системы, например, установка скрипта из Ссылка и назначение его как действия ctrl-Q как глобального ярлыка.     

ответ дан JanKanis 28.02.2018 в 18:04
0

Для меня отключить Ctrl+Q ярлык по всей системе - не идеальное решение, потому что оно запрещает другим приложениям, кроме Firefox, Chrome и т. д., когда вы используете этот ярлык - например, IntelliJ IDEA использует Ctrl+Q as привязка по умолчанию, чтобы показать всплывающее окно быстрой документации.

Если вы ищете решение только для Firefox, я настоятельно рекомендую Отключить плагин Ctrl-Q Shortcut . По-моему, это лучший вариант, чем keyconfig , упомянутый @qbi, потому что его источник доступен на GitHub , а keyconfig доступен только как двоичный файл.

    
ответ дан falconepl 27.06.2015 в 17:05