Как установить и использовать голосовые команды?

6

Как я могу дать свою собственную команду с помощью микрофона.

Я хотел бы дать команду вроде:

" Обновить систему сейчас "

Таким образом, система автоматически выполнит обновление apt-get

Я видел

, но я получаю ошибку:

$ @penreturns 06:34 PM ~
 > sudo apt-get install gnome-voice-control
[sudo] password for r00t: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package gnome-voice-control

Мои данные:

$ @penreturns 06:56 PM ~
uname -a; cat /etc/lsb-release; gnome-shell --version 
Linux penreturns 3.4.1-030401-generic #201206041411 SMP Mon Jun 4 18:12:24
UTC 2012 x86_64 x86_64 x86_64 GNU/Linux DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04 
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu 12.04.1 LTS" 
GNOME Shell 3.5.4
$ @penreturns 06:56 PM ~

Как начать этот проект. Какой пакет мне нужен. Какой сценарий мне нужно изучить.

    
задан penreturns 29.09.2012 в 13:09
источник

2 ответа

7

Голосовое управление для Ubuntu 12.04

Привет,

Я думаю, Gnome-Voice-Control не находится в репозиториях («Невозможно найти пакет gnome-voice-control»). И как вы видите здесь , он больше не развит.

Если вы хотите сделать и использовать свои собственные голосовые команды (« Обновить систему сейчас )), попробуйте Саймон слушает .

Simon Listens - Установка:

sudo add-apt-repository ppa:grasch-simon-listens/simon
sudo apt-get update
sudo apt-get install simon

В Simon, например, вы можете записать команду и связать ее с bash-script , делая то, что хотите, или привяжите его к DBUS-командам . Таким образом, очень легко создать любую голосовую команду! Я попробовал, и все работает нормально. Чем больше вы тренируете свои речевые команды, тем лучше он понимает ваши команды после этого.

Альтернативно попробуйте VEDICS . Но до сих пор он может обрабатывать только одну (?) Команду.

С наилучшими пожеланиями

    
ответ дан user85321 01.10.2012 в 20:25
0

Я попытался установить simon на Elementary и получил эту ошибку:

The following packages have unmet dependencies:
 simon : Depends: libattica0 but it is not installable
E: Unable to correct problems, you have held broken packages.

Я загрузил следующий пакет: Ссылка

и установил его с помощью:

sudo dpkg -i ./libattica0_0.1.3-0ubuntu1_amd64.deb

, и это решило проблему :)

    
ответ дан Tcuc 06.07.2014 в 18:33