Ошибка при установке пакетов с помощью Synaptic в Ubuntu 14.04?

6

Каждый раз, когда я устанавливаю что-то с помощью синаптики, я получаю следующую ошибку, когда я подробно нажимаю:

(synaptic:16174): GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed

Пакеты установлены без каких-либо проблем.

У меня есть google, и я знаю, что у многих людей такая ошибка. Мне было интересно, если это уже анализируется или есть исправление для него ...

СООБЩЕНИЕ ОШИБКИ От Synaptic:

    
задан Mr_Chmod 07.05.2014 в 22:18
источник

2 ответа

3
                      Direct Response from Ubuntu Bugs - Ubuntu Quality

"Это ошибка, похоже, является одним из тех предупреждающих сообщений, которые не действительно нарушить программу вообще, поэтому с точки зрения сортировки ошибок это «Низкое» (значение Ubuntu Bug Triage) или «Незначительное» (Debian BTS важность), важность ошибки.

    
ответ дан Mr_Chmod 11.05.2014 в 22:31
3

В Launchpad имеется полный отчет об ошибке : GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed

Подробнее см. сообщения № 52 и № 60.

Причина была ошибка в libvte-2.90 (Terminal Emulator), используемая в Trusty 14.04. Это было исправлено в libvte-2.91. Вам нужно перестроить Synaptic против этой обновленной библиотеки.

У меня есть последняя версия synaptic rebuild для Trusty 14.04 в моем Ubuntu Photo Video Applications PPA , если вы хотите обновить:

$ sudo apt-add-repostory ppa:anton+/photo-video-apps
$ sudo apt-get update
    
ответ дан Antonio 22.01.2016 в 14:03