curl: (1) Протокол https не поддерживается или отключен в libcurl

6

Я пытаюсь установить фреймворк, используя curl , но я продолжаю получать это раздражающее сообщение об ошибке curl: (1) Protocol https not supported or disabled in libcurl . Кто-нибудь знает, как это исправить? Я стоп!

Спасибо

    
задан Waiyl Karim 10.10.2015 в 18:10
источник

2 ответа

5

Мне удалось решить проблему через несколько часов, пытаясь выполнить различные варианты! Вот что я сделал:

Загружено с Ссылка .

tar -xzf curl-***.tar.gz
cd curl-*.*.*
./configure --with-ssl
make
sudo make install
    
ответ дан Waiyl Karim 10.10.2015 в 22:25
источник
1

Официально cURL не поддерживает HTTPS. Ответ выше не работал для меня, уже попробовал загрузить новые версии, добавленные командой --with-ssl, и не повезло, этот ответ решил мою проблему.

Ссылка

  • Ссылка на контент -
  

Я до сих пор не знаю, почему использование Aptitude устанавливает версию без поддержки HTTPS, но создание с нуля делало трюк:

     

git clone Ссылка   sudo apt-get build-dep curl   cd curl   ./buildconf   ./configure   делать   sudo make install

     

Теперь curl -V дает

     

Протоколы: файл dict ftp ftps gopher http https imap imaps ldap ldaps pop3 pop3s rtmp rtsp smb smbs smtp smtps telnet tftp   Особенности: IDN IPv6 Largefile NTLM NTLM_WB SSL libz TLS-SRP UnixSockets

    
ответ дан Rian Brüggemann 18.08.2017 в 22:19