Как установить последнюю версию Graphviz?

6

По умолчанию пакет graphviz устарел. Поэтому я попытался получить последний пакет: Ссылка

Пытаясь установить libgraphviz4, он жалуется на конфликт с libcdt4
поэтому я apt-get удаляю это, тогда он жалуется на конфликт с libpathplan4
поэтому я apt-get удаляю это, тогда он жалуется на конфликт с libxdot4
поэтому я apt-get удалить это, то он жалуется ...

Dependency is not satisfiable: libgd2-noxpm (>=2.0.36~rc1~dfsg)|libgd2-xpm (>=2.0.36~rc1~dfsg)

Самый близкий пакет, который я мог найти, - libgd2-xpm-dev 2.1.0-2
Установка, которая не устраняет проблему.

Как это установить?

Решение «дублированного вопроса», которое было помечено этим, не помогает. Пытаться установить пакет не удается, и даже предлагает вещи в цикле. Мне непонятно, почему libgd2-xpm-dev 2.1.0-2 в любом случае не удовлетворяет зависимость.

$ sudo apt-get install libgd2-xpm
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libgd2-xpm is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libgd2-xpm:i386

E: Package 'libgd2-xpm' has no installation candidate

$ sudo apt-get install libgd2-xpm:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libgd2-xpm:i386 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libgd2-xpm

E: Package 'libgd2-xpm:i386' has no installation candidate
    
задан CuriousStudent 08.02.2014 в 10:43
источник

1 ответ

6

Я предполагаю, что вы пытаетесь установить этот пакет, используя sudo dpkg -i package , ну, что обычно приводит к проблемам с зависимостью пакета, поэтому я обычно рекомендую использовать gdebi. Если у вас есть проблемный пакет, удалите его. Вы можете проверить использование sudo apt-get check . Теперь о бизнесе:

sudo apt-get install gdebi-core

С этим у нас есть готовый gdebi. Теперь, если вы используете 64-битную систему, вам может понадобиться установить 64-разрядный пакет, аналогично 32-битным.

Теперь вот забавный материал ...

sudo gdebi graphviz_2.37.20140208.0545-1\~saucy_amd64.deb 
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Building data structures... Done 
Building data structures... Done 
This package is uninstallable
Dependency is not satisfiable: libgd2-noxpm (>= 2.0.36~rc1~dfsg)|libgd2-xpm (>= 2.0.36~rc1~dfsg)

И здесь вы остановились. Причина в том, что стабильный пакет зависит от пакета, который был удален из Debian, ergo Ubuntu 13.10:

libgd2 (2.0.36~rc1~dfsg-6.1) unstable; urgency=low

  * Non-maintainer upload.
  * Support multi-arch: (closes: #652496)
    - Mark libgd2-xpm, libgd2-noxpm, libgd2-xpm-dev and libgd2-noxpm-dev
      as same.
    - Adjust d-shlibs and dh-buildinfo build-dependency.
  * Drop .la files.

 -- Bastian Blank   Sun, 13 May 2012 09:16:37 +0000

Это зависимости от графика, поэтому они должны изменить их на libgd2-xpm-dev и libgd2-noxpm-dev соответственно. Если это так, вы должны загрузить последнюю сборку вместо 2.38 или новее, которая включает в себя правильные зависимости.

    
ответ дан Braiam 09.02.2014 в 05:44
источник