Xmonad изменяет шрифт в терминале

6

Когда я запускаю GNOME-Terminal в 12.04, это тот тип шрифта, который я получаю:

Мне очень нравится и хочу сохранить его. Когда я запускаю Xmonad и запускаю GNOME-терминал, я получаю этот шрифт:

Почему они разные, и что более важно, как я могу изменить его, чтобы получить первый шрифт, когда я использую Xmonad?

    
задан oadams 05.09.2012 в 03:41
источник

4 ответа

4

Имела точно такую же проблему (с тем же шрифтом), кажется, что ваш нижний скриншот использует «hintsfull», в то время как верхний использует «hintslight» (который я предпочитаю)

Я исправил проблему, используя следующие ~ / .Xresources

Xft.dpi: 96
Xft.lcdfilter: lcddefault
Xft.antialias: true
Xft.autohint: true
Xft.hinting: true
Xft.hintstyle: hintslight
Xft.rgba: rgb

Для справки я также использую следующее ~ / .gtkrc-2.0

gtk-theme-name="Ambiance"
gtk-icon-theme-name="ubuntu-mono-dark"
gtk-font-name="Ubuntu 11"
gtk-cursor-theme-name="DMZ-White"
gtk-cursor-theme-size=24
gtk-toolbar-style=GTK_TOOLBAR_BOTH_HORIZ
gtk-toolbar-icon-size=GTK_ICON_SIZE_LARGE_TOOLBAR
gtk-button-images=0
gtk-menu-images=0
gtk-enable-event-sounds=1
gtk-enable-input-feedback-sounds=0
gtk-xft-antialias=1
gtk-xft-hinting=1
gtk-xft-hintstyle="hintslight"
gtk-xft-rgba="rgb"

Кроме того, вы также можете запускать Xmonad под Gnome (в этом случае Gnome управляет AA, и вам не нужно возиться с конфигурационными файлами), поскольку он довольно широко документирован, но для меня это немного портит цель наличия сверхлегкого WM.

    
ответ дан Nicolas Bonnefon 30.10.2013 в 00:17
1

Мне кажется, что они одни и те же шрифты, но с разными уровнями намеков.

Вы действительно проверяли, что они одинаковы в меню терминала: Edit > Настройки профиля > Общее?

Этот вопрос кажется похожим: Без сглаживания с Xmonad

Возможно, эти сообщения также будут полезны: Ссылка

    
ответ дан hnasarat 05.09.2012 в 06:06
1

Простейшим решением этой проблемы для меня было использование

import XMonad
import XMonad.Config.Gnome

main = do
    xmonad $ gnomeConfig

вместо defaultConfig в файле ~/.xmonad/xmonad.hs .

    
ответ дан user1691145 30.08.2015 в 03:46
0

Это не проверенный ответ, но я считаю, что вы можете установить его в ~ / .fonts.conf , как это сообщение FreeBSD показывает (выдержка):

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>

    <!-- default quality settings -->
    <match target="font">
        <edit mode="assign" name="rgba">      <const>none</const>     </edit>
        <edit mode="assign" name="antialias"> <bool>true</bool>       </edit>
        <edit mode="assign" name="autohint">  <bool>true</bool>       </edit>
        <edit mode="assign" name="hinting">   <bool>true</bool>       </edit>
        <edit mode="assign" name="hintstyle"> <const>hintfull</const> </edit>
    </match>

    <!-- reduce ringing ==> requires freetype2 'WITH_LCD_FILTERING=yes' -->
    <match target="font">
        <edit mode="assign" name="lcdfilter"> <const>lcdlight</const> </edit>
    </match>

    <!-- disable autohinting for bold fonts -->
    <match target="font">
        <test compare="more" name="weight">   <const>medium</const> </test>
        <edit mode="assign"  name="autohint"> <bool>false</bool>    </edit>
    </match>

    <!-- disable autohinting for fonts that don't need it -->
    <match target="pattern" name="family">
        <test qual="any" name="family">
          <string>Andale Mono</string>
          <string>Arial</string>
          <string>Arial Black</string>
          <string>Comic Sans MS</string>
          <string>Courier New</string>
          <string>Georgia</string>
          <string>Impact</string>
          <string>Trebuchet MS</string>
          <string>Tahoma</string>
          <string>Times New Roman</string>
          <string>Verdana</string>
          <string>Webdings</string>
       </test>
       <edit mode="assign" name="hinting">  <bool>true</bool>  </edit>
       <edit mode="assign" name="autohint"> <bool>false</bool> </edit>
    </match>
</fontconfig>
    
ответ дан nfirvine 29.09.2012 в 02:24