Источники неавторизованного программного обеспечения

6

Установка My Lucid (10.04) недавно начала предупреждать меня, что обновленные пакеты не прошли проверку. Например, если я открываю диспетчер обновлений и нажимаю кнопку «Установить обновления», он предупреждает меня, что Вы собираетесь установить программное обеспечение, которое не может быть аутентифицировано ! Это может привести к тому, что злоумышленник может повредить или взять под контроль вашу систему.

Я не помню этого раньше. Думаю, похоже, что у меня нет правильных ключей для проверки подписей.

Обновить с дополнительной информацией:

Я получаю предупреждение для пакетов all , включая apt и linux-image.

Это то, что находится в моих комментариях /etc/apt/sources.list (без комментариев)

deb http://us.archive.ubuntu.com/ubuntu/ lucid main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ lucid main restricted
deb http://us.archive.ubuntu.com/ubuntu/ lucid-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ lucid-updates main restricted
deb http://us.archive.ubuntu.com/ubuntu/ lucid universe
deb-src http://us.archive.ubuntu.com/ubuntu/ lucid universe
deb http://us.archive.ubuntu.com/ubuntu/ lucid-updates universe
deb-src http://us.archive.ubuntu.com/ubuntu/ lucid-updates universe
deb http://us.archive.ubuntu.com/ubuntu/ lucid multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ lucid multiverse
deb http://us.archive.ubuntu.com/ubuntu/ lucid-updates multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ lucid-updates multiverse
deb http://us.archive.ubuntu.com/ubuntu/ lucid-security main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ lucid-security main restricted
deb http://us.archive.ubuntu.com/ubuntu/ lucid-security universe
deb-src http://us.archive.ubuntu.com/ubuntu/ lucid-security universe
deb http://us.archive.ubuntu.com/ubuntu/ lucid-security multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ lucid-security multiverse

обновление 2:

Независимо от того, что было неправильно, это уже не так, поэтому я не смогу проверить какие-либо предлагаемые решения.

    
задан dkagedal 21.09.2010 в 11:23
источник

2 ответа

4

Иногда, когда сетевое соединение прерывает apt-get update (или обновление ежедневного обновления ежедневного пакета), файл подписи не записывается, в результате apt кричит об отсутствии аутентификации. В большинстве ситуаций (при условии, что неподходящая конфигурация прозрачной системы кеширования находится между вами и Интернетом), простой sudo apt-get update решит проблему.

    
ответ дан Kees Cook 27.10.2010 в 08:01
2

Скорее всего, вы добавили репозиторий PPA и не добавили соответствующие ключи. Самый простой способ сделать это - отключить все PPA и пройти через каждый и бросить их на add-apt-repository . Это добавит его обратно в ваши источники, но также

Итак, если вы видите что-то вроде этого:

deb http://ppa.launchpad.net/f-spot/f-spot-ppa/ubuntu lucid main

Run:

sudo add-apt-repository ppa:f-spot/f-spot-ppa

Я думаю, вы также можете выбросить всю сурролину, так что это тоже должно быть верно:

sudo add-apt-repository deb http://ppa.launchpad.net/f-spot/f-spot-ppa/ubuntu lucid main

Промойте и повторите все ваши нестандартные источники программного обеспечения.

    
ответ дан Oli 21.09.2010 в 11:56