Проблемы с обновлением: пакеты сдерживаются

6

Когда я пытаюсь обновить, я получаю пакеты, которые сохраняются, когда я использую dist-upgrade, они будут обновлены, но я получаю это предупреждение:

Current status: 5 updates [-1].
[email protected]:~$ sudo aptitude dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading extended state information      
Initialising package states... Done
The following packages are BROKEN:
  libdrm-nouveau1 
The following NEW packages will be installed:
  libkms1{a} 
The following packages will be upgraded:
  libdrm-dev libdrm-intel1 libdrm-radeon1 libdrm2 
5 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/245kB of archives. After unpacking 2,077kB will be freed.
The following packages have unmet dependencies:
  libdrm-nouveau1: Breaks: xserver-xorg-video-nouveau (< 1:0.0.16) but 1:0.0.15+git20100219+9b4118d-0ubuntu5 is installed.
The following actions will resolve these dependencies:

Remove the following packages:
xserver-xorg-video-all
xserver-xorg-video-nouveau

Score is 188

Я не знаю, нужно ли обновлять или нет, похоже, что это может сломать мое видео

    
задан Will 24.09.2010 в 10:45
источник

2 ответа

6

Я бы не обновлял. Особенно, если у вас есть пакеты в рабочем состоянии. Никогда не запускайте частичное обновление или не устанавливайте пакеты в обратном порядке. Они так по какой-то причине. Вы управляете Maverick BETA? Если это так, то это объяснит. Вы должны дождаться, когда пакеты будут отсортированы, и они будут.

(Я действительно делаю перерыв, пишу статью в блоге, которая объясняет такие вещи прямо сейчас, странно).

    
ответ дан NightwishFan 24.09.2010 в 11:10
источник
0

исполнительская:

sudo apt-get удалить xserver-xorg-video-nouveau

удалит блокировку зависимостей и позволит вам обновить. Вы можете переустановить пакеты после обновления:

sudo apt-get install xserver-xorg-video-all

    
ответ дан user11518 26.02.2011 в 17:18