Проблема установки VLC (установка через терминал)

6

Я хотел установить VLC на Ubuntu, он не работал, обновлял систему, а обновлял ее, но все же он не работает.

Я использовал для этого как Центр программного обеспечения Ubuntu, так и Терминал.

В терминале я набрал команду sudo apt-get install vlc

Терминал сообщения об ошибке дает мне следующее.

[email protected]:~$ sudo apt-get install vlc
[sudo] password for arif: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 vlc : Depends: vlc-nox (= 2.2.0~rc1-1ppa2~trusty) but it is not going to be installed
       Depends: libavcodec56 (>= 7:2.4~) but it is not going to be installed
       Depends: libgles1-mesa (>= 7.8.1) but it is not installable or
                libgles1 but it is not installable
       Depends: libsdl-image1.2 (>= 1.2.10) but it is not installable
       Depends: libsdl1.2debian (>= 1.2.11) but it is not installable
       Depends: libva-drm1 but it is not installable
       Depends: libva-x11-1 (> 1.3.0~) but it is not installable
       Depends: libva1 (> 1.3.0~) but it is not installable
       Depends: libvlccore8 (>= 2.2.0~pre1) but it is not going to be installed
       Depends: libxcb-composite0 but it is not installable
       Depends: libxcb-xv0 (>= 1.2) but it is not installable
       Recommends: vlc-plugin-notify (= 2.2.0~rc1-1ppa2~trusty) but it is not going to be installed
       Recommends: vlc-plugin-samba (= 2.2.0~rc1-1ppa2~trusty) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Примечание. Я использую Ubuntu 14.04 LTS

    
задан Bangash 19.11.2014 в 08:18
источник

3 ответа

0

На самом деле я решил эту проблему в тот же день, проблема была в ближайшем архиве.ubuntu.com (Ubuntu Archive Server). Я изменил все его экземпляры (13 случаев в моем случае) на us.archive.ubuntu.com и это сработало. Файл конфигурации, в котором я изменил этот параметр, был /etc/apt/sources.list.

Изменить . Недавно я нашел еще один вопрос по askubuntu, принятый ответ на этот вопрос также является хорошим решением этой проблемы, если вы не хотите изменять адрес archive.ubuntu.
Вот этот вопрос.

    
ответ дан Bangash 07.12.2014 в 09:38
источник
6

Это случилось со мной после обновления с Ubuntu 14.04 до 14.10.

Я нашел это решение , которое мне помогло.

Вам нужно добавить xorg-edgers fresh X crack Репозиторий с этим кодом в терминале:

sudo add-apt-repository ppa:xorg-edgers/ppa 
apt-cache policy libgl1-mesa-glx libglapi-mesa

Затем перезагрузите компьютер. Затем обновите репозитории со следующими командами и установите VLC:

sudo apt-get update
sudo apt-get install vlc
    
ответ дан Aby 03.12.2014 в 21:05
0

Выполните следующие команды

sudo apt-get -f install

sudo dpkg --configure -a

Это должно установить все отсутствующие зависимости и настроить dpkg.

    
ответ дан Rohith Madhavan 19.11.2014 в 08:59